Bug 199657 - fltk-config --ldflags shouldn't set rpath
fltk-config --ldflags shouldn't set rpath
Status: CLOSED DUPLICATE of bug 199656
Product: Fedora
Classification: Fedora
Component: fltk (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael J Knox
Fedora Extras Quality Assurance
:
Depends On:
Blocks: FE7Target
  Show dependency treegraph
 
Reported: 2006-07-21 02:24 EDT by Anthony Green
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-12 00:42:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Anthony Green 2006-07-21 02:24:39 EDT
Description of problem:
On x86-64 systems fltk-config --ldflags prints "-L/usr/lib64
-Wl,-rpath,/usr/lib64" and then a bunch of libraries.  It should not print the
rpath bit, and the -L option isn't required either.
If you use these options within a spec file for another package, 
 rpmlint will  complain about the use of rpath in the resulting binary.

Version-Release number of selected component (if applicable):
fltk-devel-1.1.7-1.fc5

How reproducible:
Always

Steps to Reproduce:
1.See above.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Denis Leroy 2006-09-13 19:11:07 EDT
I'm hitting this bug also with with aqsis. This makes rpmlint very mad.
Comment 2 Rex Dieter 2006-12-12 00:42:54 EST
I'm gonna lump this with the other fltk-config bug #199656 , symptom of the 
same problem.

*** This bug has been marked as a duplicate of 199656 ***

Note You need to log in before you can comment on or make changes to this bug.