Bug 199806 - TCP connections to RH9 machines fail to complete initial transaction
TCP connections to RH9 machines fail to complete initial transaction
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
: 199807 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-22 08:42 EDT by jdow
Modified: 2015-01-04 17:28 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-17 10:17:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jdow 2006-07-22 08:42:20 EDT
Description of problem:


Version-Release number of selected component (if applicable):
Network TCP for kernel 2.6.17-1.2142

How reproducible:
Either
http://www.nlzero.com
or
ssh nlzero.com
or
telnet nlzero.com

from a FC4 with the latest (as of 20060722) update kernel.

Steps to Reproduce:
1. http://www.nlzero.com or ssh nlzero.com or telnet nlzero.com
2. Grow old and die waiting for the initial transactions to complete.
3.
  
Actual results:
Hung connection

Expected results:
Website or login prompt or login prompt, respectively.


Additional info:
tcpdump can be generated if needed. (I'd have to reboot to 2142. I am using
2.6.16-1.2115 quite successfully at the moment.)
Comment 1 Dave Jones 2006-07-29 02:12:21 EDT
*** Bug 199807 has been marked as a duplicate of this bug. ***
Comment 2 Donovan Hill 2006-08-07 14:27:25 EDT
I have the same problem trying to connect to "http://www.valleyfirst.com". We
tried to telnet to port 80 to check if it is an application issue.

I've downgraded to the same version as the OP and it works properly.

Thanks.
Comment 3 Jeff MacDonald 2006-08-07 14:38:10 EDT
kernel Linux toast.zoidtechnologies.com 2.6.16-1.2111_FC4 #1 Sat May 20 19:59:40
EDT 2006 i686 i686 i386 GNU/Linux does *not* have this problem (I can use links
and access http://www.valleyfirst.com/ without a problem), but kernel Linux
dionysus.zoidtechnologies.com 2.6.17-1.2139_FC5 #1 Fri Jun 23 12:40:16 EDT 2006
i686 i686 i386 GNU/Linux *does* have the problem. 

toast is my firewall/nat box, dionysus is my workstation.
Comment 4 Dave Jones 2006-09-16 22:39:56 EDT
[This comment added as part of a mass-update to all open FC4 kernel bugs]

FC4 has now transitioned to the Fedora legacy project, which will continue to
release security related updates for the kernel.  As this bug is not security
related, it is unlikely to be fixed in an update for FC4, and has been migrated
to FC5.

Please retest with Fedora Core 5.

Thank you.
Comment 5 jdow 2006-09-17 02:12:36 EDT
FWIW with a recent FC5 install the telnet negotiation seems to complete. I 
can't test the ssh because I gave up the account on the old machine for 
unrelated reasons.

{^_^}  Joanne
Comment 6 Dave Jones 2006-09-17 10:17:15 EDT
thanks

Note You need to log in before you can comment on or make changes to this bug.