Bug 199820 - xen-libs mis-installs SONAME links as copies
Summary: xen-libs mis-installs SONAME links as copies
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: xen (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Xen Maintainance List
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
: 199917 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-07-22 16:44 UTC by Alexandre Oliva
Modified: 2007-11-30 22:11 UTC (History)
3 users (show)

Fixed In Version: -19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-25 17:06:26 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Alexandre Oliva 2006-07-22 16:44:30 UTC
Description of problem:
# /sbin/ldconfig
/sbin/ldconfig: /usr/lib/libblktap.so.3.0 is not a symbolic link

/sbin/ldconfig: /usr/lib64/libblktap.so.3.0 is not a symbolic link

# ls -l /usr/lib*/libblktap.so.3.0*
-rwxr-xr-x 1 root root 13896 Jul 21 17:14 /usr/lib64/libblktap.so.3.0
-rwxr-xr-x 1 root root 13896 Jul 21 17:14 /usr/lib64/libblktap.so.3.0.0
-rwxr-xr-x 1 root root 11888 Jul 21 17:16 /usr/lib/libblktap.so.3.0
-rwxr-xr-x 1 root root 11892 Jul 21 17:16 /usr/lib/libblktap.so.3.0.0

Correct behavior is to install 3.0.0 as the actual library, and 3.0 -> 3.0.0 as
a symlink.  (although 3.0 is odd in the SONAME, normally people use a single
number for the SONAME)

Version-Release number of selected component (if applicable):
xen-libs-3.0.2-18

Comment 1 Jeremy Katz 2006-07-22 18:43:28 UTC
Yeah, I noticed this and sent a patch for it upstream.

Comment 2 Jeremy Katz 2006-07-24 13:29:56 UTC
*** Bug 199917 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.