Bug 199842 - Extreme latency while reading or writing from DVD drive
Extreme latency while reading or writing from DVD drive
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeff Garzik
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2006-07-23 03:15 EDT by Russell Strong
Modified: 2013-07-02 22:29 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-05-06 12:09:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Russell Strong 2006-07-23 03:15:13 EDT
Description of problem:

Whenever I read or write a DVD the machine exhibits really high latency.  The
mouse updates about 2 time per second.  Everything is slow.  CPU usage is less
than 10%.

From dmesg:

Probing IDE interface ide1...
hdc: _NEC DVD+/-RW ND-6650A, ATAPI CD/DVD-ROM drive
ide1 at 0x170-0x177,0x376 on irq 15
hdc: ATAPI 24X DVD-ROM DVD-R CD-R/RW drive, 2048kB Cache
Uniform CD-ROM driver Revision: 3.20

kernel is 2.6.17-1.2157_FC5smp

I know this is not much information.  If you could let me know where to look I
can get more.

Version-Release number of selected component (if applicable):

How reproducible:

Any time reading or writing from a DVD.
Comment 1 Dave Jones 2006-07-25 23:52:30 EDT
sounds like DMA isn't enabled on the drive for some reason.
can you confirm this with hdparm -i /dev/hdc
Comment 2 Russell Strong 2006-07-26 06:32:39 EDT
[root@dropbear ~]# hdparm -i /dev/hdc


 Model=_NEC DVD+/-RW ND-6650A, FwRev=102C, SerialNo=
 Config={ Removeable DTR<=5Mbs DTR>10Mbs nonMagnetic }
 RawCHS=0/0/0, TrkSize=0, SectSize=0, ECCbytes=0
 BuffType=unknown, BuffSize=0kB, MaxMultSect=0
 (maybe): CurCHS=0/0/0, CurSects=0, LBA=yes, LBAsects=0
 IORDY=yes, tPIO={min:120,w/IORDY:120}, tDMA={min:120,rec:120}
 PIO modes:  pio0 pio1 pio2 pio3 pio4
 DMA modes:  mdma0 mdma1 mdma2
 UDMA modes: udma0 udma1 *udma2

 * signifies the current active mode

[root@dropbear ~]#

If DMA was not enabled would I see a large CPU load?
Comment 3 Andreas Tunek 2006-08-22 16:32:51 EDT
I also have the same problems with the following message from dmesg:
Probing IDE interface ide1...
ide1 at 0x170-0x177,0x376 on irq 15
hda: max request size: 128KiB
hda: 78140160 sectors (40007 MB) w/1768KiB Cache, CHS=65535/16/63, UDMA(100)
hda: cache flushes not supported
 hda: hda1 hda2
hdc: ATAPI 24X DVD-ROM CD-R/RW drive, 2048kB Cache, DMA
Uniform CD-ROM driver Revision: 3.20

kernel is kernel.i686 2.6.17-1.2174_FC5 
Comment 4 Steve 2006-09-20 23:28:10 EDT
need your motherboard and chipset

ex if i boot with fedora kernel i need to add:

to get DMA on my DVD RW

you may also need more arguements:
ex: hda=noprobe hdc=noprobe combined_mode=libata
pretty much just disable ide, i don't know the proper arguement, ive tried
ide=noprobe but i get an error
Comment 5 Dave Jones 2006-10-16 16:21:27 EDT
A new kernel update has been released (Version: 2.6.18-1.2200.fc5)
based upon a new upstream kernel release.

Please retest against this new kernel, as a large number of patches
go into each upstream release, possibly including changes that
may address this problem.

This bug has been placed in NEEDINFO state.
Due to the large volume of inactive bugs in bugzilla, if this bug is
still in this state in two weeks time, it will be closed.

Should this bug still be relevant after this period, the reporter
can reopen the bug at any time. Any other users on the Cc: list
of this bug can request that the bug be reopened by adding a
comment to the bug.

In the last few updates, some users upgrading from FC4->FC5
have reported that installing a kernel update has left their
systems unbootable. If you have been affected by this problem
please check you only have one version of device-mapper & lvm2
installed.  See bug 207474 for further details.

If this bug is a problem preventing you from installing the
release this version is filed against, please see bug 169613.

If this bug has been fixed, but you are now experiencing a different
problem, please file a separate bug for the new problem.

Thank you.
Comment 6 Russell Strong 2006-10-21 07:59:27 EDT
I've worked around it by using the following:

added hdc=noprobe to kernel cmdline
added libata atapi_enabled=1 to modprobe.conf

I upgraded to the 2200 kernel, removed my workaround, tested again by playing a
DVD.  While playing the DVD I tested the interactivity by timing how long it
takes me to position the cursor over certain points on the screen.

With the original kernel mentioned in the bug report this would take about 10-15
With the 2200 kernel this would take about 4-5 seconds.  A very large
improvement.  However, sound and video were underrunning every 1-2 seconds (
which is also a big improvement ).

Comment 7 Bug Zapper 2008-04-03 23:21:36 EDT
Fedora apologizes that these issues have not been resolved yet. We're
sorry it's taken so long for your bug to be properly triaged and acted
on. We appreciate the time you took to report this issue and want to
make sure no important bugs slip through the cracks.

If you're currently running a version of Fedora Core between 1 and 6,
please note that Fedora no longer maintains these releases. We strongly
encourage you to upgrade to a current Fedora release. In order to
refocus our efforts as a project we are flagging all of the open bugs
for releases which are no longer maintained and closing them.

If this bug is still open against Fedora Core 1 through 6, thirty days
from now, it will be closed 'WONTFIX'. If you can reporduce this bug in
the latest Fedora version, please change to the respective version. If
you are unable to do this, please add a comment to this bug requesting
the change.

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we are following is outlined here:

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

And if you'd like to join the bug triage team to help make things
better, check out http://fedoraproject.org/wiki/BugZappers
Comment 8 Bug Zapper 2008-05-06 12:09:06 EDT
This bug is open for a Fedora version that is no longer maintained and
will not be fixed by Fedora. Therefore we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen thus bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.