Bug 199844 - Amaya 8.5-2 crashes on AMD64
Amaya 8.5-2 crashes on AMD64
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: amaya (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Paul F. Johnson
Fedora Extras Quality Assurance
:
: 202818 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-23 04:14 EDT by Ashish Shukla
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-14 16:34:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ashish Shukla 2006-07-23 04:14:32 EDT
Description of problem:
When starting amaya, it terminates with the following dump

-- begin dump --
Gdk-ERROR **: BadMatch (invalid parameter attributes)
  serial 109 error_code 8 request_code 56 minor_code 0
-- end dump --

Version-Release number of selected component (if applicable):
amaya-8.5-2

How reproducible:
Run amaya

Steps to Reproduce:
1. Open a terminal
2. Execute amaya
  
Actual results:
-- begin dump --
Gdk-ERROR **: BadMatch (invalid parameter attributes)
  serial 109 error_code 8 request_code 56 minor_code 0
-- end dump --

Expected results:
It should start perfectly

Additional info:
I'm running on AMD64 architecture. I've checked Fedora Extras (for IA-32), there
9.5.1.fc5 is available, but in AMD64 architecture, only 8.5-2 is available. It
seems that probably new package doesn't has the bug. And a new package should be
built for AMD64 architecture.
Comment 1 Paul F. Johnson 2006-07-23 05:09:11 EDT
9.5.1 completely fails to build under either i386 or x86_64 with the current
version of gcc in core. This has been reported upstream.
Comment 2 Paul F. Johnson 2006-08-16 18:17:55 EDT
*** Bug 202818 has been marked as a duplicate of this bug. ***
Comment 3 Leon Stringer 2006-08-23 05:59:47 EDT
Is the upstream bug on a tracker we could watch (e.g. GCC's Bugzilla)?
Comment 4 Paul F. Johnson 2006-08-23 06:04:36 EDT
The only thing you can watch is the mailing lists. From what I can gather, the
8- branch is being depricated in favour of the 9 branch.

Unfortunately, that builds happily on x86_64 but has "other" problems :-(

I'm hoping I can get something out for the middle of next week, but it will only
be the 9- branch.
Comment 5 Leon Stringer 2006-08-23 08:09:30 EDT
Yes, version 8 uses Motif widgets and the old rendering engine. Version 9 uses
WX widgets and an OpenGL rendering engine (smooth fonts, better SVG). The v8
branch is retained as a low resource usage version, presumably for those with
older hardware (or using graphics terminals). So unless you need v8 you would
normally use v9.

As far as I'm concerned, only v9 should be available from Extras, but both
versions should work, i.e. if downloaded from source (or RPM?) from the W3C site.

On FC6, nothing is working now.

As this has been reported upstream, I wondered where the report was, etc., as
Amaya is essential for me.

If a fix is expected soon, that's great.
Comment 6 Leon Stringer 2006-09-08 14:30:41 EDT
Today's CVS code *builds* on FC6 (at least it did for me). However it doesn't run.

To build it I had to remove the flex-2.5.4a-41.fc5 RPM and install flex-2.5.33
from source.

When you launch it you get an initial message:

 (amaya:7408): Gtk-CRITICAL **: gtk_widget_set_colormap: assertion `!
 GTK_WIDGET_REALIZED (widget)' failed

The window briefly appears then you get:

 The program 'amaya' received an X Window System error.
 This probably reflects a bug in the program.
 The error was 'BadMatch (invalid parameter attributes)'.
   (Details: serial 7271 error_code 8 request_code 143 minor_code 5)
   (Note to programmers: normally, X errors are reported asynchronously;
    that is, you will receive the error a while after causing it.
    To debug your program, run it with the --sync command line
    option to change this behavior. You can then get a meaningful
    backtrace from your debugger if you break on the gdk_x_error()
 function.)
Comment 7 MartinG 2006-09-24 08:45:53 EDT
Just to confirm this bug, I get

Gdk-ERROR **: BadMatch (invalid parameter attributes)
  serial 367 error_code 8 request_code 56 minor_code 0

On 2.6.17-1.2187_FC5 using amaya 9.5-1.fc5 (i386) from FC5 extras.
Comment 8 Paul F. Johnson 2006-10-14 16:34:29 EDT
Amaya is now a dead package. Closing the bug

Note You need to log in before you can comment on or make changes to this bug.