Bug 199860 - installation of nas breaks autostart of icecast because of same default port 8000
installation of nas breaks autostart of icecast because of same default port ...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: nas (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Frank Büttner
Fedora Extras Quality Assurance
:
Depends On: 210543
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-23 07:40 EDT by Peter Bieringer
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-13 03:46:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Bieringer 2006-07-23 07:40:46 EDT
Description of problem:
During regular "yum update" latest qt4 update had automatically installed "nas"
from extras repository because of required "libaudio.so.2". Unfortunately, "nas"
has default port 8000, this is the same "icecast" normally use.

Version-Release number of selected component (if applicable):
nas-1.8-6.fc5
qt4-x11-4.1.4-7.fc5
qt4-devel-4.1.4-7.fc5
icecast-2.3.1-1.fc5


How reproducible:
Always.

Steps to Reproduce:
1. install FC5
2. install and run "icecast"
3. install "qt4-x11" (e.g. needed for "keepass")
4. yum update
  
Actual results:
After reboot, "nas" starts before "icecast" so second one cannot start anymore

Expected results:
Sort out, whether "nas" and "icecast" should use the same default port 8000
Comment 1 Michael Schwendt 2006-10-12 13:12:46 EDT
*ping*   (as a result of current fedora-extras-list topic)
Comment 2 Frank Büttner 2006-10-12 15:30:51 EDT
The problem, is that both app's use port witch are free for all.(>1023)
Comment 3 Andreas Thienemann 2006-10-12 18:35:03 EDT
Mhm. I just closed the bug report against shoutcast, as I do not consider two
apps using the same port as a bug.

However, it is a bit problematic  as nas seems to be pulled in automagically.

We could change the defaults of the server ports, but somehow, I think this is a
bad idea.

People are used to having shoutcast on 8000.

Does qt4 really need nas? Does nas has to be launched by default? That might
prevent the problem in this case.
Comment 4 Warren Togami 2006-10-13 01:27:18 EDT
The vast majority of users do not have any need for nas.  And very few users
would use icecast too.  Neither should enable use of the port by default with
the package installed but software not explicitly configured or run.
Comment 5 Frank Büttner 2006-10-13 03:46:54 EDT
All Qt based app's that will play sound's need nas.

Note You need to log in before you can comment on or make changes to this bug.