Bug 199866 - Anaconda fails to enable swap on md device
Anaconda fails to enable swap on md device
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Jones
Depends On:
  Show dependency treegraph
Reported: 2006-07-23 12:04 EDT by Göran Uddeborg
Modified: 2008-05-06 12:09 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-05-06 12:09:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Error message from anaconda (167 bytes, text/plain)
2006-07-23 12:04 EDT, Göran Uddeborg
no flags Details
/proc/mdstat at the time anaconda fails (229 bytes, text/plain)
2006-07-26 15:27 EDT, Göran Uddeborg
no flags Details
/tmp/anaconda.log (15.65 KB, text/plain)
2006-07-26 15:35 EDT, Göran Uddeborg
no flags Details
/tmp/syslog (29.76 KB, text/plain)
2006-07-26 15:36 EDT, Göran Uddeborg
no flags Details
/proc/mdstat during normal operation (280 bytes, text/plain)
2006-07-26 15:39 EDT, Göran Uddeborg
no flags Details

  None (edit)
Description Göran Uddeborg 2006-07-23 12:04:29 EDT
Description of problem:
When trying to upgrade from FC4 to FC5 it stops early complaining that md1 is
not a swap partition.

In more detail: I am trying to upgrade remotely using kickstart.  The boot line
looks like this.

ks=hd:sda1:/ks.cfg display=... ramdisk_size=8192 console=tty0 console=ttyS0,9600

The root partition, with /etc/fstab referred to in the message, is on another md
device (ext3 on LVM volume on md2).  So the raid assembly seems to work
correctly.  To further rule out this potential problem, I added mdadm assembly
commands in ks.cfg to explicitly assemble all md devices.  But I still get the
same error message from anaconda.

How reproducible:
Every time
Comment 1 Göran Uddeborg 2006-07-23 12:04:29 EDT
Created attachment 132884 [details]
Error message from anaconda
Comment 2 Jeremy Katz 2006-07-25 16:22:45 EDT
Can you get /tmp/anaconda.log and /tmp/syslog from the system?
Comment 3 Göran Uddeborg 2006-07-25 16:29:12 EDT
It is a bit tricky.  I'm doing the upgrade remotely.  I have access to the
serial console and I give anaconda an X display to use.  But I can't do a switch
to a different vt and use the shell that ususally runs there.

As soon as I have the opportunity I'll go locally to the machine and do this,
but I'm not sure how soon that will be.

Unless there is some way to access the log with the setup I have?
Comment 4 Jeremy Katz 2006-07-25 16:31:21 EDT
If you do vnc (add 'vnc' to the boot command line) instead of a remote X
display, then you'll get a "hit enter for a shell" prompt on your serial console.
Comment 5 Göran Uddeborg 2006-07-25 16:54:27 EDT
I tried vnc first.  "vnc" and "vncconnect=..." on boot line.  But then I hit bug
179635 instead.  
Comment 6 Göran Uddeborg 2006-07-25 17:06:21 EDT
But thinking about it, I never tried without vncconnect.  Maybe that doesn't
trigger bug 179635.  I'll try it, and see what info I can get.
Comment 7 Göran Uddeborg 2006-07-26 15:24:19 EDT
Without "vncconnect" the vnc installation worked fine. :-)  So I used the shell
on the serial console you told me about.  Here is some more details:

md0 and md2, with /boot and / respectively, are assembled.  But md1 has not been
assembled for some reason.

I can see in the syslog that it tries to assemble md1, and is looking at sda2. 
But it apparently never finds out that sdb2 is the other part.  Why would that
be?  After that it gives up, and I suppose the remaining problems are
consequences of this.

In the shell I did a chroot to /mnt/sysimiga, and then
"mdadm --assemble /dev/md1".  That worked without problems.  And after that,
"swapon -a" worked too and started swap on /dev/md1.

I should note that I am using the respin of 20060621 from Fedora Unity.  To rule
out the possibility it could be a problem introduced in the respin, I'm
torrenting home the original distribution to right now.  I'll come back with an
update about this in a day or so.
Comment 8 Göran Uddeborg 2006-07-26 15:27:37 EDT
Created attachment 133094 [details]
/proc/mdstat at the time anaconda fails
Comment 9 Göran Uddeborg 2006-07-26 15:35:31 EDT
Created attachment 133095 [details]
Comment 10 Göran Uddeborg 2006-07-26 15:36:45 EDT
Created attachment 133096 [details]
Comment 11 Göran Uddeborg 2006-07-26 15:39:28 EDT
Created attachment 133097 [details]
/proc/mdstat during normal operation
Comment 12 Jeremy Katz 2006-07-26 16:49:44 EDT
raid autorun isn't ever looking at sdb2 -- does it have the raid flag set?  (Run
parted /dev/sdb, type print -- see if raid is in the flags list)
Comment 13 Göran Uddeborg 2006-07-26 17:04:23 EDT
I didn't think about checking that, but yes, it seems to have the flag.

(parted) print                                                            
Disk geometry for /dev/sdb: 0.000-190782.210 megabytes
Disk label type: msdos
Minor    Start       End     Type      Filesystem  Flags
1          0.031    400.056  primary   ext3        boot, raid
2        400.056   4494.748  primary               raid
3       4494.749 190782.210  primary               raid
Comment 14 Göran Uddeborg 2006-07-27 17:18:32 EDT
The behaviour is the same with the original FC5 DVD distribution.  The problem
is not introduced in the respin.
Comment 15 Bug Zapper 2008-04-03 23:22:20 EDT
Fedora apologizes that these issues have not been resolved yet. We're
sorry it's taken so long for your bug to be properly triaged and acted
on. We appreciate the time you took to report this issue and want to
make sure no important bugs slip through the cracks.

If you're currently running a version of Fedora Core between 1 and 6,
please note that Fedora no longer maintains these releases. We strongly
encourage you to upgrade to a current Fedora release. In order to
refocus our efforts as a project we are flagging all of the open bugs
for releases which are no longer maintained and closing them.

If this bug is still open against Fedora Core 1 through 6, thirty days
from now, it will be closed 'WONTFIX'. If you can reporduce this bug in
the latest Fedora version, please change to the respective version. If
you are unable to do this, please add a comment to this bug requesting
the change.

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we are following is outlined here:

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

And if you'd like to join the bug triage team to help make things
better, check out http://fedoraproject.org/wiki/BugZappers
Comment 16 Bug Zapper 2008-05-06 12:09:35 EDT
This bug is open for a Fedora version that is no longer maintained and
will not be fixed by Fedora. Therefore we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen thus bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.