Bug 179635 - receiving X Error when running vnc under anaconda
receiving X Error when running vnc under anaconda
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: vnc (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Tkac
David Lawrence
:
: 188294 206116 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-01 15:01 EST by Chris Lumens
Modified: 2013-04-30 19:33 EDT (History)
7 users (show)

See Also:
Fixed In Version: 4.1.2-5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-25 09:10:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace error output running vncconfig on x86_64 (15.25 KB, text/plain)
2006-02-03 14:31 EST, magaoaye
no flags Details
Screenshot (72.27 KB, image/jpeg)
2006-05-25 13:37 EDT, Konrad Rzeszutek
no flags Details
vnc-vnconnect-on-x86_64.patch (496 bytes, patch)
2006-08-01 14:07 EDT, Mark McLoughlin
no flags Details | Diff

  None (edit)
Description Chris Lumens 2006-02-01 15:01:05 EST
anaconda supports a VNC mode so the installation may be viewed remotely.  We run
the following command to set this up:

/usr/bin/vncconfig -display :1 -connect <remote host>

We are immediately getting the following error message back:

X Error: BadLength
 Request Major Code 134 (VNC-EXTENSION)
 Request Minor code 7 ()
 Error Serial #7
 Current Serial #7

I've only tested i386, x64_64, and ppc64.  Only x86_64 displays this problem. 
What would be useful in debugging this?
Comment 1 magaoaye 2006-02-03 14:31:44 EST
Created attachment 124116 [details]
strace error output running vncconfig on x86_64

Would STRACE help? I attached my strace output above FYI  
(assumed: display 32, viewer: 192.168.3.30):
command execeute:

strace vncconfig -display :32 -connect 192.168.3.30:5932  2>log
Comment 2 Jason Tibbitts 2006-04-19 16:26:58 EDT
This is causing me much pain as well.  I am capable of patching anaconda and
rebuilding the installation images if necessary and would be happy to test in
any way necessary.
Comment 3 Konrad Rzeszutek 2006-05-25 13:37:37 EDT
Created attachment 129999 [details]
Screenshot

FYI: I also see this - but on 32-bit machines. Here is the screenshot - a bit
different error codes.
Comment 4 Jason Tibbitts 2006-05-25 14:19:57 EDT
Looks like a completely separate issue.  vnc is actually running in your case.
Comment 5 Mark McLoughlin 2006-08-01 14:06:03 EDT
Okay, I think I've figured this out.

Problem was with vncExtInit.cc and dix/dispatch.c compiled with differently laid
out ClientRec structures.

With dix/dispatch.c, _XSERVER64 was defined causing Mask to be a unsigned int
(i.e. CARD32) whereas vncExtInit.cc without _XSERVER64 making Mask be an
unsigned long.

Attaching a patch which follows the approach of vnc-64bit.patch - that is, make
sure xorg-server.h gets included before the X defs


Comment 6 Mark McLoughlin 2006-08-01 14:07:37 EDT
Created attachment 133424 [details]
vnc-vnconnect-on-x86_64.patch
Comment 7 Mark McLoughlin 2006-08-02 04:20:10 EDT
*** Bug 188294 has been marked as a duplicate of this bug. ***
Comment 8 Callum Lerwick 2006-08-02 13:35:08 EDT
I just tried the patch and it seems to work. I get clipboard propagation again yay!
Comment 9 Adam Tkac 2006-10-17 05:38:52 EDT
*** Bug 206116 has been marked as a duplicate of this bug. ***
Comment 10 Adam Tkac 2006-10-25 09:10:50 EDT
(In reply to comment #6)
> Created an attachment (id=133424) [edit]
> vnc-vnconnect-on-x86_64.patch

Thank you for patch


Note You need to log in before you can comment on or make changes to this bug.