Bug 199891 - Metacity fails to start with message [ error while loading shared libraries: libGL.so.1: failed to map segment from shared object: Permission denied ]
Metacity fails to start with message [ error while loading shared libraries: ...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mesa (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Søren Sandmann Pedersen
: Reopened
Depends On:
Blocks: FC6Blocker
  Show dependency treegraph
 
Reported: 2006-07-23 23:33 EDT by Wade Mealing
Modified: 2014-06-18 05:08 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-26 13:45:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wade Mealing 2006-07-23 23:33:29 EDT
Description of problem:

Upgraded to rawhide as of yesterday ( Monday, July 24 2006 ).  Rebooted system
today and metacity wont start.


Version-Release number of selected component (if applicable):
metacity-2.15.5-6.1
mesa-libGL-6.5-13.1
selinux-policy-2.3.3-9


How reproducible:
Every time

Steps to Reproduce:
1. Enable selinux in targeted policy.
2. reboot machine
3. Use gdm to log in to a user that would start the metacity window manager.
  
Actual results:

Metacity fails to start, messages above were shown by starting metacity from
failsafe terminal.

Expected results:

Metacity to start

Additional info:

This is -NOT- the same as the other metacity bugs recently closed in rawhide.
Comment 1 Wade Mealing 2006-07-23 23:54:36 EDT
Messages recieved:

avc: denied { execmem} for pid=3023 comm="metacity"
scontext=user_u:system_r:unconfined_t:s0
tscontextuser_u:system_r:unconfined_t:s0 tclass=process

metacity: error while loading shared libraries: libGL.so.1: failed to map
segment from shared object: Permission denied

Comment 2 Daniel Walsh 2006-07-24 10:53:50 EDT

*** This bug has been marked as a duplicate of 188295 ***
Comment 3 Wade Mealing 2006-07-24 22:08:40 EDT
This is not a duplicate of this bug, note that the avc messages are different,
the error messages are different, and the follow on bug that , the bug that it
is pointed to ( https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=188401 )
says it is fixed in rawhide.

I am running versions that are greater than the versions mentioned in that bug,
and the problem still persists.

Comment 4 Adam Jackson 2006-07-26 13:45:31 EDT
Fixed in 6.5-19 or better.

The problem was with how TLS dispatch was implemented.  It used a writable text
section to reduce the textrel cost, but selinux doesn't allow that.  Switching
back to non-TLS dispatch fixes it for now.

Note You need to log in before you can comment on or make changes to this bug.