Bug 200206 - [bn-IN] Incorrect spellings in localedef-components
Summary: [bn-IN] Incorrect spellings in localedef-components
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords: i18n
Depends On:
Blocks: 200230
TreeView+ depends on / blocked
 
Reported: 2006-07-26 07:16 UTC by Runa Bhattacharjee
Modified: 2016-11-24 16:02 UTC (History)
5 users (show)

Fixed In Version: 2.4.90-23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-22 15:35:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Corrected localedef file for Bengali India (bn_IN) locale (6.71 KB, application/octet-stream)
2006-07-26 07:16 UTC, Runa Bhattacharjee
no flags Details
diff from the bn_IN original localedef file and the modifed bn_IN localedef file (4.34 KB, text/x-patch)
2006-08-08 10:19 UTC, Runa Bhattacharjee
no flags Details
Locale Definition - All Day bn_IN text putout (306 bytes, application/octet-stream)
2006-08-11 06:45 UTC, Satyabrata Maitra
no flags Details
Latest patch, used "diff -uNrp" (2.93 KB, patch)
2006-08-16 08:46 UTC, Mayank Jain
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Sourceware 3034 None None None Never

Description Runa Bhattacharjee 2006-07-26 07:16:26 UTC
Created attachment 133049 [details]
Corrected localedef file for Bengali India (bn_IN) locale

Comment 1 Runa Bhattacharjee 2006-07-26 07:16:26 UTC
Description of problem:

Some contents in the Date section of the localedef had incorrect spellings

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.From the gdm, choose language as Bengali India
2. Click on  Date on the mail panel
3. 
  
Actual results:

Tuesday shows as "মà¦à¦à¦²à¦¬à¦¾à¦°" with short form as "মà¦à§à¦à¦²:


Expected results:

Should be spelt as "মà¦à§à¦à¦²à¦¬à¦¾à¦°" with short form as "মà¦à§à¦à¦²"   

Additional info:

Corrected localedef file for bn-IN locale is attached

Comment 2 Ulrich Drepper 2006-07-30 18:46:35 UTC
Why do you change so much in this file?  All possible copy statements should be
retained.  This applies at least to LC_MEASUREMENT, LC_TELEPHONE.  I haven't
checked the rest.  Please remove these.

Also, in LC_MESSAGES, the strings differ from the bn_BD content.  Why is there a
difference?  If the new text in your bn_IN file is correct, shouldn't then the
text in bn_BD be fixed?  I doubt that the spelling is different just because of
the country.

Is it possible to unify the LC_TIME section of bn_HI and bn_BD?  If yes, please
move the real definition to bn_BD.

Finally, you shouldn't send entire files.  Use the diff command on the command
line and send the output.


Comment 3 Runa Bhattacharjee 2006-07-31 04:08:53 UTC
(In reply to comment #2)
> Why do you change so much in this file?  All possible copy statements should be
> retained.  This applies at least to LC_MEASUREMENT, LC_TELEPHONE.  I haven't
> checked the rest.  Please remove these.

These are copied from the hi_IN localedef file. In case a user decides to
install only the bn_IN locale besides the en_US (and hi_IN is not installed)
will the bn_IN get the hi_IN file to replicate values from? iirc, the values
were put for both the bn_IN and as_IN files as a failsafe. If they are not
required I can remove them.
> 
> Also, in LC_MESSAGES, the strings differ from the bn_BD content.  Why is there a
> difference?  If the new text in your bn_IN file is correct, shouldn't then the
> text in bn_BD be fixed?  I doubt that the spelling is different just because of
> the country.

There are spelling differences in the two countries. Secondly there were some
spelling errors in the original bn_IN file which was a rehashed version of the
bn_BD file. bn_BD localedef file is managed by the bn community, hence I
personally do not think it prudent to modify it.
> 
> Is it possible to unify the LC_TIME section of bn_HI and bn_BD?  If yes, please
> move the real definition to bn_BD.

Not sure about bn_HI.
> 
> Finally, you shouldn't send entire files.  Use the diff command on the command
> line and send the output.
> 
Sorry for that. Shall send the diffs from now on.



Comment 4 Jakub Jelinek 2006-08-03 10:20:33 UTC
copy statements affect locale sources only, those are small and always the whole
set is installed.
The compiled locale files created by localedef are self-contained, even if
the source contained copy statements.

Comment 5 Runa Bhattacharjee 2006-08-08 10:19:50 UTC
Created attachment 133777 [details]
diff from the bn_IN original localedef file and the modifed bn_IN localedef file

Attaching a diff file.


Modified:

LC_TIME
Entries for Tuesday, January and February had incorrect spellings, which have
been corrected. As mentioned earlier the bn_BD file is maintained by members of
the community and I am informing them. I am part of the bn_IN community.

Added:
LC_PAPER

----------------------------------------

(in respect to earlier attached file):
Reverted:
LC_MEASUREMENT
LC_TELEPHONE
LC_MESSAGES

In LC_MESSAGES (to be copied from bn_CD file), the text for "yesexpr" and
"noexpr" are respectively [<localized yes>yY] and [<localized no>nN]. Is this
the correct format for indic languages? This issue is highlighted as the hi_IN
(hindi provides the basic format for a number of indic languages) file uses the
format [yY] and [nN] *without* the localized 'yes', 'no' content in the yesexpr
and noexpr entities.
--------------------------------------------------------------------------------

Comment 6 Mayank Jain 2006-08-11 06:35:35 UTC
Folks can use script in
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=200230#c28 to test the
spellings/unicode-points in the locale.

Comment 7 Satyabrata Maitra 2006-08-11 06:45:32 UTC
Created attachment 134004 [details]
Locale Definition - All Day bn_IN text putout

This is the locale definition output redirected to the text file instead of
terminal. Pls have a look.

Comment 8 Mayank Jain 2006-08-11 07:05:38 UTC
Upstream bug - http://sources.redhat.com/bugzilla/show_bug.cgi?id=3034

Please attach the final patch for bn_IN locale to upstream bug too, once its
finalized here.

Thanks,
Mayank

Comment 9 Mayank Jain 2006-08-16 08:46:41 UTC
Created attachment 134283 [details]
Latest patch, used "diff -uNrp"

Patch generated with "diff -uNrp" command, hence obsoleting previous patch.

Also, checked the resultant bn_IN file with "localedef -i bn_IN -f UTF-8
/usr/lib/locale/bn_IN" command.

Comment 10 Mayank Jain 2006-08-16 09:04:47 UTC
Over to you Jakub :)
Thanks,
Mayank

Comment 11 Ulrich Drepper 2006-08-19 15:36:44 UTC
Patch is upstream, will be in next rawhide build.

Comment 12 Ulrich Drepper 2006-08-22 15:35:41 UTC
The rawhide build with the changes is 2.4.90-23.  Maybe even an earlier one. 
Please test that code.

Comment 13 Mayank Jain 2006-09-01 08:48:04 UTC
Thanks guys :)


Note You need to log in before you can comment on or make changes to this bug.