Bug 200230 - [locale-def] Locale Definition is not in desired pattern for some Locales
[locale-def] Locale Definition is not in desired pattern for some Locales
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
: i18n
Depends On: 200206
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-26 08:59 EDT by Satyabrata Maitra
Modified: 2008-08-02 19:40 EDT (History)
6 users (show)

See Also:
Fixed In Version: 2.4.90-23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-22 11:40:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
bn_IN Locale def for all 7 days and with Month August (50.39 KB, image/png)
2006-08-10 04:47 EDT, Satyabrata Maitra
no flags Details
ml_IN Locale def for all 7 days and with Month August (46.67 KB, image/png)
2006-08-10 04:48 EDT, Satyabrata Maitra
no flags Details
ml_IN Locale def for all 7 days and with Month August (51.10 KB, image/png)
2006-08-10 04:48 EDT, Satyabrata Maitra
no flags Details
pa_IN Locale def for Saturday with Month August (8.75 KB, image/png)
2006-08-10 04:50 EDT, Satyabrata Maitra
no flags Details
Patch for pa_IN (600 bytes, patch)
2006-08-10 05:33 EDT, Mayank Jain
no flags Details | Diff
patch for or_IN (571 bytes, patch)
2006-08-10 06:12 EDT, Mayank Jain
no flags Details | Diff
ml_IN Locale def for all 7 days and with Month August in text tile. (248 bytes, application/octet-stream)
2006-08-10 06:44 EDT, Satyabrata Maitra
no flags Details
Script to check validness of spellings/unicodes for a locale (2.13 KB, text/x-python)
2006-08-10 08:07 EDT, Mayank Jain
no flags Details
output of test runner script (1.50 KB, text/plain)
2006-08-10 08:09 EDT, Mayank Jain
no flags Details
Final version of script to check correctness of the locale values (day/month) names (4.43 KB, text/plain)
2006-08-10 08:51 EDT, Mayank Jain
no flags Details
Patch for ml_IN (2.70 KB, patch)
2006-08-10 09:01 EDT, Mayank Jain
no flags Details | Diff
Patch for bn_IN (2.93 KB, patch)
2006-08-16 04:48 EDT, Mayank Jain
no flags Details | Diff
Corrected patch for ml_IN (2.69 KB, patch)
2006-08-17 04:30 EDT, Mayank Jain
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Sourceware 3034 None None None Never
Sourceware 3035 None None None Never

  None (edit)
Description Satyabrata Maitra 2006-07-26 08:59:17 EDT
Description of problem:
Locale definition is not maintaining desired format for some locales, like Indic
- (bn_IN, or_IN, ml_IN, pa_IN), European - (es_ES, it_IT), and Chinese - (zh_TW).

Problems are different for differnt locales. Those are described below :

bn_IN
(Wednesday is ok, but for tuesday, thursday, saturday, showing problem)
or_IN
(Instead of displaying the month it's displaying "7".)

ml_IN
(Some rendering error)

pa_IN
(Spelling mistake for Saturday)

es_ES
(Spanish follows a day-month-year pattern so the correct pattern should be:
mié 12 jul 2006 00:15:45 UTC
(name of the day, day, month in lowercase, year, time))

it_IT
(it_IT put the day before the month : mer 12 lug)

zh_TW
(It can make it perfect by:
(1) Putting brackets for the first character. (optional)
(2) Putting a space after month.
(3) Putting a space and a character (日) after date.
So it will look like: (三) 7 月 12 日 00:15:45 UTC 2006)

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. LANG=bn_IN.UTF-8 date;  like this
2.
3.
  
Actual results:
Some locale has problem with its format in locale definition.

Expected results:
All locale definition format should be OK and maintain specific format of that
locale.

Additional info:
Package maintainer is requested to contact translators of concerned locale to
take brief informations, if required. Or update this bug with requirement, thus
I can contact translators to provide the further informations.
Comment 1 Ulrich Drepper 2006-07-30 14:37:20 EDT
This is not how it works.  The locales are maintained by outside people.  RH
just uses the upstream code.

If something things there is a problem the procedure is
1. get the sources
2. create a patch
3. ask current maintainer
4. if s/he agrees submit for inclusion
5. if no reply after a while, submit for inclusion with appropriate comment

I can see that the *_IN locales have problems.  That data is mostly generated
automatically from a database.  I might be willing to accept patches directly.

But all the other locales have to be coordinated with the maintainer of the
locale.  I have no reason to believe anyone more than the original maintainer
and I cannot make the call myself.
Comment 2 Jens Petersen 2006-08-07 03:00:26 EDT
smaitra, are you or majain able to generate a patch for the Indic locale?
Comment 3 Mayank Jain 2006-08-07 06:51:00 EDT
Smaitra, can you please give detailed errors for these locales, so as we can
then ping respective language maintainers?

> ml_IN
> (Some rendering error)
> 
> pa_IN
> (Spelling mistake for Saturday)

Thanks,
Mayank
Comment 4 Jens Petersen 2006-08-08 04:23:46 EDT
bn is already covered by bug 200206.
Comment 5 Satyabrata Maitra 2006-08-10 04:47:22 EDT
Created attachment 133912 [details]
bn_IN Locale def for all 7 days and with Month August
Comment 6 Satyabrata Maitra 2006-08-10 04:48:16 EDT
Created attachment 133913 [details]
ml_IN Locale def for all 7 days and with Month August
Comment 7 Satyabrata Maitra 2006-08-10 04:48:54 EDT
Created attachment 133914 [details]
ml_IN Locale def for all 7 days and with Month August
Comment 8 Satyabrata Maitra 2006-08-10 04:50:59 EDT
Created attachment 133915 [details]
pa_IN Locale def for Saturday with Month August
Comment 9 Satyabrata Maitra 2006-08-10 04:53:02 EDT
Mayank

Please ask the Language Maintainer of respective Locale to confirm which day is
showing wrong. I gave info with all days in screenshot.
Comment 10 Satyabrata Maitra 2006-08-10 04:55:07 EDT
Please fint the screenshot attachments for Locale def for Langs or_IN, bn_IN,
ml_IN and pa_IN. in all screenshots for each locale the day started with Monday
except pa_IN. in pa_IN only Saturday's screenshot has been given as required.

Satya
Comment 11 Satyabrata Maitra 2006-08-10 04:55:25 EDT
Please find the screenshot attachments for Locale def for Langs or_IN, bn_IN,
ml_IN and pa_IN. in all screenshots for each locale the day started with Monday
except pa_IN. in pa_IN only Saturday's screenshot has been given as required.

Satya
Comment 12 Mayank Jain 2006-08-10 05:33:12 EDT
Created attachment 133920 [details]
Patch for pa_IN

Patch with correct spelling of Saturday ਸ਼ਨਿੱਚਰਵਾਰ

Python converts this string to unicode
>>> a="ਸ਼ਨਿੱਚਰਵਾਰ"
>>> a.decode("utf-8")
u'\u0a36\u0a28\u0a3f\u0a71\u0a1a\u0a30\u0a35\u0a3e\u0a30'
Comment 13 Mayank Jain 2006-08-10 05:42:17 EDT
> ml_IN
> (Some rendering error)

The unicode present in /usr/share/i18n/locales/ml_IN file for thursday are
correct, the problem is with rendering, hence the solution is out of scope for
this bug.

Smaitra, please file a bug for that agains a correct component, probably
system-config-date...

Thanks,
Mayank
Comment 14 Mayank Jain 2006-08-10 06:06:44 EDT
Regarding or_IN

Rendering bugs in 
abday
 "<U0B36><U0B41><U0B15><U0B4D><U0B30>";/ ଶୁକ୍ର  - rendering problem - fraiday
Mon
 "<U0B2B><U0B47><U0B2C><U0B4D><U0B30><U0B41><U0B5F><U0B3E><U0B30><U0B40>";/
ଫେବ୍ରୁୟାରୀ  - rendering problem - February
 "<U0B05><U0B2A><U0B4D><U0B30><U0B47><U0B32>";/ ଅପ୍ରେଲ  - rendering problem - april
 "<U0B28><U0B2D><U0B47><U0B2E><U0B4D><U0B2C><U0B30>";/  - rendering problem -
november
 "<U0B21><U0B3F><U0B38><U0B47><U0B2E><U0B4D><U0B2C><U0B30>"  - rendering problem
- december

Unicode bugs in
 "<U0B2E><U0B47>";/ ମଇ (correct) - May (spelling mistake)

Smaitra, i'm attaching a patch for the unicode error, rendering bugs are to be
filled separately from this bug.

Thanks.
Comment 15 Mayank Jain 2006-08-10 06:09:29 EDT
Oops, just missed one rendering bug for or_IN

in "Mon" section
"<U0B38><U0B47><U0B2A><U0B4D><U0B1F><U0B47><U0B2E><U0B4D><U0B2C><U0B30>";/
ସେପ୍ଟେମ୍ବର  - rendering problem - september
Comment 16 Mayank Jain 2006-08-10 06:12:09 EDT
Created attachment 133927 [details]
patch for or_IN
Comment 17 Mayank Jain 2006-08-10 06:18:22 EDT
Smaitra, work for or_IN, pa_IN is done... bn_IN is covered under bug 200206
Only locale now left is ml_IN

Can you please attach the output of #7 and #8 in text format as rendering on g-t
is very bad & broken.

you can redirect the outputs to a file & upload the file here in BZ.

LANG=ml_IN.UTF-8 date -f designate >> ml_IN.file

now upload this file.

Thanks.
Comment 18 Satyabrata Maitra 2006-08-10 06:44:22 EDT
Created attachment 133929 [details]
ml_IN Locale def for all 7 days and with Month August in text tile.

Mayank

Dates starting with Sunday here, as u required. Please find the attachment.
Comment 19 Satyabrata Maitra 2006-08-10 06:46:24 EDT
Please tell me if anything more you require
Comment 20 Ani Peter 2006-08-10 07:31:55 EDT
Dear Mayank,

The corrected month names as follows...

mon     "<U0D1C><U0D28><U0D41><U0D35><U0D30><U0D3F>";/  ജനുവരി  
"<U0D2B><U0D46><U0D2C><U0D4D><U0D30><U0D41><U0D35><U0D30><U0D3F>";/ഫെബ്രുവരി
"<U0D2E><U0D3E><U0D31><U0D41><U0D4D><U0D1A><U0D4D><U0D1A><U0D4D>";/ --  spelling
mistake;correct one - മാര്‍ച്ച്  
"<U0D0F><U0D2A><U0D4D><U0D31><U0D3F><U0D32><U0D41><U0D4D>";/  -- spelling
mistake;correct one - ഏപ്രില്‍ 
"<U0D2E><U0D46><U0D2F><U0D4D>";/മെയ്
"<U0D1C><U0D42><U0D23><U0D41><U0D4D>";/ -- spelling mistake;correct one - ജൂണ്‍
"<U0D1C><U0D42><U0D32><U0D48>";/ജൂലൈ
"<U0D06><U0D17><U0D38><U0D4D><U0D24><U0D4D>";/ -- spelling mistake;correct one -
ആഗസ്റ്റ്
"<U0D38><U0D46><U0D2A><U0D4D><U0D24><U0D02><U0D2C><U0D31><U0D41><U0D4D>";/ --
spelling mistake;correct one - സെപ്റ്റംബര്‍
"<U0D12><U0D15><U0D4D><U0D1F><U0D4B><U0D2C><U0D31><U0D41><U0D4D>";/ -- spelling
mistake;correct one - ഒക്ടോബര്‍
"<U0D28><U0D35><U0D02><U0D2C><U0D31><U0D41><U0D4D>";/ -- spelling
mistake;correct one - നവംബര്‍
"<U0D21><U0D3F><U0D38><U0D02><U0D2C><U0D31><U0D41><U0D4D>" -- spelling
mistake;correct one - ഡിസംബര്‍
%

Please note that in gedit again there is rendering issues so cannot see even the
correct ones properly.

Thanks
Ani
Comment 21 Ani Peter 2006-08-10 07:35:36 EDT
Hi Miyank, 

Copying the same again along with the English month names so that you do not get
any confusion.

JANUARY - "<U0D1C><U0D28><U0D41><U0D35><U0D30><U0D3F>";/  ജനുവരി  
FEBRUARY -
"<U0D2B><U0D46><U0D2C><U0D4D><U0D30><U0D41><U0D35><U0D30><U0D3F>";/ഫെബ്രുവരി
MARCH - "<U0D2E><U0D3E><U0D31><U0D41><U0D4D><U0D1A><U0D4D><U0D1A><U0D4D>";/ -- 
spelling mistake;correct one - മാര്‍ച്ച്  
APRIL - "<U0D0F><U0D2A><U0D4D><U0D31><U0D3F><U0D32><U0D41><U0D4D>";/  --
spelling mistake;correct one - ഏപ്രില്‍ 
MAY - "<U0D2E><U0D46><U0D2F><U0D4D>";/മെയ്
JUNE - "<U0D1C><U0D42><U0D23><U0D41><U0D4D>";/ -- spelling mistake;correct one - ജൂണ്‍
JULY - "<U0D1C><U0D42><U0D32><U0D48>";/ജൂലൈ
AUGUST - "<U0D06><U0D17><U0D38><U0D4D><U0D24><U0D4D>";/ -- spelling
mistake;correct one - ആഗസ്റ്റ്
SEPTEMBER -
"<U0D38><U0D46><U0D2A><U0D4D><U0D24><U0D02><U0D2C><U0D31><U0D41><U0D4D>";/ --
spelling mistake;correct one - സെപ്റ്റംബര്‍
OCTOBER - "<U0D12><U0D15><U0D4D><U0D1F><U0D4B><U0D2C><U0D31><U0D41><U0D4D>";/ --
spelling mistake;correct one - ഒക്ടോബര്‍
NOVEMBER - "<U0D28><U0D35><U0D02><U0D2C><U0D31><U0D41><U0D4D>";/ -- spelling
mistake;correct one - നവംബര്‍
DECEMBER - "<U0D21><U0D3F><U0D38><U0D02><U0D2C><U0D31><U0D41><U0D4D>" --
spelling mistake;correct one - ഡിസംബര്‍

Thanks,
Ani
Comment 22 Mayank Jain 2006-08-10 08:07:58 EDT
Created attachment 133937 [details]
Script to check validness of spellings/unicodes for a locale

See the script for usage
Comment 23 Mayank Jain 2006-08-10 08:09:07 EDT
Created attachment 133938 [details]
output of test runner script

Shows the failing cases in ml_IN language
Comment 24 Mayank Jain 2006-08-10 08:10:16 EDT
January PASSED
February PASSED
March FAILED
Incorrect unicode points =
<U0D2E><U0D3E><U0D31><U0D41><U0D4D><U0D1A><U0D4D><U0D1A><U0D4D>
Correct unicode points   =
<U0D2E><U0D3E><U0D30><U0D4D><U200D><U0D1A><U0D4D><U0D1A><U0D4D>
April FAILED
Incorrect unicode points = <U0D0F><U0D2A><U0D4D><U0D31><U0D3F><U0D32><U0D41><U0D4D>
Correct unicode points   =
<U0D0F><U0D2A><U0D4D><U0D30><U0D3F><U0D32><U0D4D><U200D><U0020>
May PASSED
June FAILED
Incorrect unicode points = <U0D1C><U0D42><U0D23><U0D41><U0D4D>
Correct unicode points   = <U0D1C><U0D42><U0D23><U0D4D><U200D>
July PASSED
August FAILED
Incorrect unicode points = <U0D06><U0D17><U0D38><U0D4D><U0D24><U0D4D>
Correct unicode points   = <U0D06><U0D17><U0D38><U0D4D><U0D31><U0D4D><U0D31><U0D4D>
September FAILED
Incorrect unicode points =
<U0D38><U0D46><U0D2A><U0D4D><U0D24><U0D02><U0D2C><U0D31><U0D41><U0D4D>
Correct unicode points   =
<U0D38><U0D46><U0D2A><U0D4D><U0D31><U0D4D><U0D31><U0D02><U0D2C><U0D30><U0D4D><U200D>
October FAILED
Incorrect unicode points =
<U0D12><U0D15><U0D4D><U0D1F><U0D4B><U0D2C><U0D31><U0D41><U0D4D>
Correct unicode points   =
<U0D12><U0D15><U0D4D><U0D1F><U0D4B><U0D2C><U0D30><U0D4D><U200D>
November FAILED
Incorrect unicode points = <U0D28><U0D35><U0D02><U0D2C><U0D31><U0D41><U0D4D>
Correct unicode points   = <U0D28><U0D35><U0D02><U0D2C><U0D30><U0D4D><U200D>
December FAILED
Incorrect unicode points = <U0D21><U0D3F><U0D38><U0D02><U0D2C><U0D31><U0D41><U0D4D>
Correct unicode points   = <U0D21><U0D3F><U0D38><U0D02><U0D2C><U0D30><U0D4D><U200D>
8 cases failed!
Comment 25 Ani Peter 2006-08-10 08:23:05 EDT
Miyank,

Full week days :

Sunday - ഞായര്‍
Monday - തിങ്കള്‍
Tuesday - ചൊവ്വ
Wednesday - ബുധന്‍
Thursday - വ്യാഴം
Friday - വെള്ളി
Saturday - ശനി

Abbreaviated Month names:

January - ജനു
February - ഫെബ്
March - മാര്‍
April - ഏപ്ര
May - മെ
June - ജൂൻണ്‍
July - ജൂലൈ
August - ആഗ്
September- സെപ്
October - ഒക്ടോ
November - നവം
December - ഡിസം

Thanks,
Ani
Comment 26 Ani Peter 2006-08-10 08:40:28 EDT
Miyank,

Abbreaviated week days: :

Sunday - ഞാ
Monday - തി
Tuesday - ചൊ
Wednesday - ബു
Thursday - വ്യാ
Friday - വെ
Saturday - à´¶

Thanks
Ani
Comment 27 Ani Peter 2006-08-10 08:41:15 EDT
Mayank,

Abbreaviated week days: :

Sunday - ഞാ
Monday - തി
Tuesday - ചൊ
Wednesday - ബു
Thursday - വ്യാ
Friday - വെ
Saturday - à´¶

Thanks
Ani
Comment 28 Mayank Jain 2006-08-10 08:51:38 EDT
Created attachment 133939 [details]
Final version of script to check correctness of the locale values (day/month) names

Python script
Comment 29 Mayank Jain 2006-08-10 08:53:11 EDT
Result of running script in #28 for ml_IN locale

---------------
Month names - full
January PASSED
February PASSED
XX March FAILED
	Incorrect unicode points =
<U0D2E><U0D3E><U0D31><U0D41><U0D4D><U0D1A><U0D4D><U0D1A><U0D4D>
	Correct unicode points   =
<U0D2E><U0D3E><U0D30><U0D4D><U200D><U0D1A><U0D4D><U0D1A><U0D4D>
XX April FAILED
	Incorrect unicode points = <U0D0F><U0D2A><U0D4D><U0D31><U0D3F><U0D32><U0D41><U0D4D>
	Correct unicode points   =
<U0D0F><U0D2A><U0D4D><U0D30><U0D3F><U0D32><U0D4D><U200D><U0020>
May PASSED
XX June FAILED
	Incorrect unicode points = <U0D1C><U0D42><U0D23><U0D41><U0D4D>
	Correct unicode points   = <U0D1C><U0D42><U0D23><U0D4D><U200D>
July PASSED
XX August FAILED
	Incorrect unicode points = <U0D06><U0D17><U0D38><U0D4D><U0D24><U0D4D>
	Correct unicode points   = <U0D06><U0D17><U0D38><U0D4D><U0D31><U0D4D><U0D31><U0D4D>
XX September FAILED
	Incorrect unicode points =
<U0D38><U0D46><U0D2A><U0D4D><U0D24><U0D02><U0D2C><U0D31><U0D41><U0D4D>
	Correct unicode points   =
<U0D38><U0D46><U0D2A><U0D4D><U0D31><U0D4D><U0D31><U0D02><U0D2C><U0D30><U0D4D><U200D>
XX October FAILED
	Incorrect unicode points =
<U0D12><U0D15><U0D4D><U0D1F><U0D4B><U0D2C><U0D31><U0D41><U0D4D>
	Correct unicode points   =
<U0D12><U0D15><U0D4D><U0D1F><U0D4B><U0D2C><U0D30><U0D4D><U200D>
XX November FAILED
	Incorrect unicode points = <U0D28><U0D35><U0D02><U0D2C><U0D31><U0D41><U0D4D>
	Correct unicode points   = <U0D28><U0D35><U0D02><U0D2C><U0D30><U0D4D><U200D>
XX December FAILED
	Incorrect unicode points = <U0D21><U0D3F><U0D38><U0D02><U0D2C><U0D31><U0D41><U0D4D>
	Correct unicode points   = <U0D21><U0D3F><U0D38><U0D02><U0D2C><U0D30><U0D4D><U200D>
=> 8 cases failed!


Month names - Abb
January PASSED
February PASSED
XX March FAILED
	Incorrect unicode points = <U0D2E><U0D3E><U0D31><U0D4D>
	Correct unicode points   = <U0D2E><U0D3E><U0D30><U0D4D><U200D>
XX April FAILED
	Incorrect unicode points = <U0D0F><U0D2A><U0D4D><U0D31><U0D3F><U0D32><U0D4D>
	Correct unicode points   = <U0D0F><U0D2A><U0D4D><U0D30>
XX May FAILED
	Incorrect unicode points = <U0D46><U0D2E><U0D2F><U0D4D>
	Correct unicode points   = <U0D2E><U0D46>
XX June FAILED
	Incorrect unicode points = <U0D1C><U0D42><U0D23><U0D4D>
	Correct unicode points   = <U0D1C><U0D42><U0D7B><U0D23><U0D4D><U200D>
XX July FAILED
	Incorrect unicode points = <U0D1C><U0D42><U0D48><U0D32>
	Correct unicode points   = <U0D1C><U0D42><U0D32><U0D48>
XX August FAILED
	Incorrect unicode points = <U0D06><U0D17>
	Correct unicode points   = <U0D06><U0D17><U0D4D>
XX September FAILED
	Incorrect unicode points = <U0D46><U0D38><U0D2A><U0D4D><U0D24><U0D02>
	Correct unicode points   = <U0D38><U0D46><U0D2A><U0D4D>
XX October FAILED
	Incorrect unicode points = <U0D12><U0D15><U0D4D><U0D48><U0D1F>
	Correct unicode points   = <U0D12><U0D15><U0D4D><U0D1F><U0D4B>
November PASSED
December PASSED
=> 8 cases failed!


Day names - full
XX Sunday FAILED
	Incorrect unicode points = <U0D1E><U0D3E><U0D2F><U0D31><U0D41><U0D4D>
	Correct unicode points   = <U0D1E><U0D3E><U0D2F><U0D30><U0D4D><U200D>
XX Monday FAILED
	Incorrect unicode points = <U0D24><U0D3F><U0D19><U0D4D><U0D15><U0D33><U0D41><U0D4D>
	Correct unicode points   = <U0D24><U0D3F><U0D19><U0D4D><U0D15><U0D33><U0D4D><U200D>
Tuesday PASSED
XX Wednesday FAILED
	Incorrect unicode points = <U0D2C><U0D41><U0D27><U0D28><U0D41><U0D4D>
	Correct unicode points   = <U0D2C><U0D41><U0D27><U0D28><U0D4D><U200D>
Thursday PASSED
Friday PASSED
Saturday PASSED
=> 3 cases failed!


Day names - Abb
Sunday PASSED
Monday PASSED
Tuesday PASSED
Wednesday PASSED
Thursday PASSED
Friday PASSED
Saturday PASSED
=> 0 cases failed!
---------------
Comment 30 Mayank Jain 2006-08-10 09:01:22 EDT
Created attachment 133940 [details]
Patch for ml_IN
Comment 31 Mayank Jain 2006-08-10 09:06:17 EDT
JSingh, SBehera, APeter, thanks for your time.
Reassigning the bug to glibc maintainer
Comment 33 Mayank Jain 2006-08-11 03:00:00 EDT
Upstream bug (for Indic) - http://sources.redhat.com/bugzilla/show_bug.cgi?id=3034
Upstream bug (for others) - http://sources.redhat.com/bugzilla/show_bug.cgi?id=3035
Comment 34 Mayank Jain 2006-08-11 03:03:35 EDT
Jakub,

If you can get the "right" translations for the mistakes in other locales (other
than indic), you can use script in
https://bugzilla.redhat.com/bugzilla/process_bug.cgi#c28 to generate the correct
unicode points.

Thanks,
Mayank
Comment 35 Mayank Jain 2006-08-11 03:06:23 EDT
I'm sorry, the link for script is
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=200230#c28
Comment 36 Ulrich Drepper 2006-08-13 01:44:51 EDT
I've applied the pa_IN, or_IN, and ml_IN patches.

But I'm not going to change anything for the other three locales.  As said
before you have to talk to the maintainer of the locale.

I want to close this bug.  It should not have been opened with all these
different issues and non-issues.  Always open one bug per locale.
Comment 37 Mayank Jain 2006-08-14 02:57:41 EDT
Hi Drepper,

Since bn_IN is being covered under bug 200206, we need to follow that bug for
bn_IN patch.

I'm sorry, but I know little about non-indic locales. Maybe, we can add them in
the CC list & ask them for help...
Comment 38 Mayank Jain 2006-08-14 03:01:19 EDT
Drepper, can you please check the patch in
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=200206#c5

If its correct, we can go on & include that in here & atleast fix the indic
locales completely...

Thanks,
Mayank
Comment 39 Mayank Jain 2006-08-14 03:28:13 EDT
Drepper...
Just for quick ref... If i copy the new locale to /usr/share/i18n/locales &
reboot, will the new locale be available?

Or is there any other way to do it?

Thanks,
Mayank
Comment 40 Jakub Jelinek 2006-08-14 03:41:30 EDT
Re #39, no, it won't.  You need to run localedef to compile it.
If the locale is in /usr/share/i18n/locales, then:
localedef -i ml_IN -f UTF-8 /usr/lib/locale/ml_IN.UTF-8
echo $?
Apparently that's a step you haven't done in the ml_IN case, see BZ#3034.
Please always try to compile locales before submission and make sure there are
no errors nor warnings.
Comment 41 Mayank Jain 2006-08-14 03:45:02 EDT
Point noted Jakub :-)
Thanks!
Comment 42 Mayank Jain 2006-08-16 04:48:35 EDT
Created attachment 134284 [details]
Patch for bn_IN

Checked the resultant bn_IN file with "localedef -i bn_IN -f UTF-8
/usr/lib/locale/bn_IN" command.
Comment 43 Mayank Jain 2006-08-16 04:53:19 EDT
or_IN - tested passed with localedef
pa_IN - tested passed with localedef
ml_IN - Failing (investigating)
bn_IN - tested passed with localedef
Comment 44 Mayank Jain 2006-08-17 02:56:46 EDT
Hi Ani, can you please check whats wrong with the strings in
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=200230#c30

Reference to problem - http://sources.redhat.com/bugzilla/show_bug.cgi?id=3034#c6

Problem seems to be here - June - ജൂൻണ്‍
Can you please chk whats wrong here?
Comment 45 Mayank Jain 2006-08-17 04:30:41 EDT
Created attachment 134368 [details]
Corrected patch for ml_IN

Corrected patch, tested with localedef command.
Comment 46 Mayank Jain 2006-08-17 04:39:42 EDT
I *think* there are more errors in ml_IN patch... investigating.
Comment 47 Mayank Jain 2006-08-17 06:04:07 EDT
Patch in https://bugzilla.redhat.com/bugzilla/process_bug.cgi#c45 is correct
patch, manually tested the unicode points.

Thanks,
Mayank
Comment 48 Mayank Jain 2006-08-17 06:26:34 EDT
Oops, I meant Comment 45 in this bug :)
Comment 49 Jakub Jelinek 2006-08-22 11:31:16 EDT
The latest ml_IN and bn_IN changes are now in glibc-2.4.90-23 in rawhide.
Anything else missing or can we finally close this?
Comment 50 Ulrich Drepper 2006-08-22 11:40:55 EDT
If there is anthing else separate new bugs should be filed.  It is simply not
acceptable to have these kind of unorganized dumping grounds.
Comment 51 Mayank Jain 2006-08-31 05:51:41 EDT
I agree Ulrich :)
Comment 52 Ulrich Drepper 2007-02-13 15:49:08 EST
I'm closing this bug.  If there are any remaining issues open separate new bugs.

Note You need to log in before you can comment on or make changes to this bug.