Bug 2002290 - [4.8] kube-proxy's userspace implementation consumes excessive CPU
Summary: [4.8] kube-proxy's userspace implementation consumes excessive CPU
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 4.7
Hardware: All
OS: Linux
high
high
Target Milestone: ---
: 4.8.z
Assignee: Dan Winship
QA Contact: zhaozhanqi
URL:
Whiteboard:
: 2063357 (view as bug list)
Depends On: 2002288
Blocks: 2002291
TreeView+ depends on / blocked
 
Reported: 2021-09-08 13:07 UTC by Dan Winship
Modified: 2022-03-14 14:36 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 2002288
: 2002291 (view as bug list)
Environment:
Last Closed: 2021-09-27 19:53:12 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift kubernetes pull 952 0 None open Bug 2002290: [4.8] userspace: Don't sync every iptables rule on every service change 2021-09-13 16:40:17 UTC
Github openshift sdn pull 347 0 None open Bug 2002290: [4.8] proxy: don't re-check every userspace proxy rule on every change 2021-09-13 16:40:17 UTC
Red Hat Product Errata RHBA-2021:3632 0 None None None 2021-09-27 19:53:29 UTC

Comment 3 zhaozhanqi 2021-09-18 03:16:19 UTC
Move this to verified according to comment 1

Comment 6 errata-xmlrpc 2021-09-27 19:53:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.8.13 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:3632

Comment 7 Dan Winship 2022-03-14 14:36:14 UTC
*** Bug 2063357 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.