Bug 2002291 - [4.7] kube-proxy's userspace implementation consumes excessive CPU
Summary: [4.7] kube-proxy's userspace implementation consumes excessive CPU
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 4.7
Hardware: All
OS: Linux
high
high
Target Milestone: ---
: 4.7.z
Assignee: Dan Winship
QA Contact: zhaozhanqi
URL:
Whiteboard:
: 2008247 (view as bug list)
Depends On: 2002290
Blocks: 2002292
TreeView+ depends on / blocked
 
Reported: 2021-09-08 13:09 UTC by Dan Winship
Modified: 2021-10-12 19:52 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 2002290
: 2002292 (view as bug list)
Environment:
Last Closed: 2021-10-12 19:51:43 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift kubernetes pull 953 0 None Merged Bug 2002291: [4.7]: userspace: Don't sync every iptables rule on every… 2021-09-28 08:48:31 UTC
Github openshift sdn pull 348 0 None Merged Bug 2002291: [4.7] proxy: don't re-check every userspace proxy rule on every change 2021-09-28 08:48:35 UTC
Red Hat Product Errata RHBA-2021:3686 0 None None None 2021-10-12 19:51:59 UTC

Comment 1 zhaozhanqi 2021-09-16 06:02:14 UTC
Verified this bug with cluster-bot launch openshift/sdn#348

Comment 4 zhaozhanqi 2021-09-23 07:57:11 UTC
Move to verified according to comment 1

Comment 6 Mohamed Mahmoud 2021-10-07 15:14:43 UTC
*** Bug 2008247 has been marked as a duplicate of this bug. ***

Comment 8 errata-xmlrpc 2021-10-12 19:51:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.7.33 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:3686


Note You need to log in before you can comment on or make changes to this bug.