Bug 20025 - SMP problems w/ old initscripts + errata kernel (no /boot/kernel.h)
SMP problems w/ old initscripts + errata kernel (no /boot/kernel.h)
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
6.0
All Linux
medium Severity high
: ---
: ---
Assigned To: Michael K. Johnson
Brock Organ
:
: 20026 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-30 05:58 EST by Pekka Savola
Modified: 2007-04-18 12:29 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-14 22:03:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pekka Savola 2000-10-30 05:58:12 EST
I've been plagued by this one problem for a long time now.  As it came
across today, I pinpointed it.

If you're using a new kernel (errata 2.2.16-3, ext2 2.2.17-5) on older
system (RH60), compiling SMP modules (e.g. external network
drivers from ftp.scyld.com) will fail because SMP related issues are not
defined and modules are compiled for UP.  Manually defining -D__SMP__ or
friends won't help either because other stuff is left out too.

This is caused by the fact that those errata kernels don't
Require: initscripts new enough which create /boot/kernel.h at boot.

Updated initscripts would be probably too much to ask, but _please_ at
least 
Require: decent initscript versions :-)
Comment 1 Daniel Roesen 2000-10-31 08:37:45 EST
*** Bug 20026 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.