Bug 200278 - RECENT YUM UPDATE RESULTS IN DELL / INTEL CPU FAILURES
RECENT YUM UPDATE RESULTS IN DELL / INTEL CPU FAILURES
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
i686 Linux
medium Severity urgent
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-26 13:27 EDT by Steve Wells
Modified: 2014-01-21 17:54 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-04 11:25:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Wells 2006-07-26 13:27:39 EDT
Description of problem:

Fedora Core 4 installation running fine for several months.  Last Yum update 
approx 2 months ago.  After recent Yum update the DELL 2850 with Intel CPU 
generates PROC1 CPU failures, system locking up & the front panel displaying 
amber CPU failure condition.  This condition frequently occurs when rebooting 
or shutting down the system but occurs at other times, intermittently, as well.

Version-Release number of selected component (if applicable):
FC4

How reproducible:
regularly but intermittent

Steps to Reproduce:
1. normal operation, shutdown -h now or shutdown -r now
2. 
3.
  
Actual results:
system locks up, PROC1 failure condition displayed in amber on front panel.

Expected results:
not die

Additional info:
  There also may be a correlation with a display issue - note that DELL has 
previously supplied updated ATI drivers which were installed & working OK - 
now the console video seems to be problematic, too.  Also note that DELL has a 
BIOS v05 upgrade that is reportedly required for other systems or problem 
areas (in RedHat) but is not available for FC4 and Dell support advises should 
not be necessary in this situation + configuration.
Comment 1 Seth Vidal 2006-07-26 13:30:17 EDT
pretty sure this is NOT a yum issue.
Comment 2 Steve Wells 2006-07-26 13:36:21 EDT
Thank you - concur kernel issue in recent modification (unknowingly) 
downloaded by Yum.
Comment 3 Dave Jones 2006-09-16 22:12:03 EDT
[This comment added as part of a mass-update to all open FC4 kernel bugs]

FC4 has now transitioned to the Fedora legacy project, which will continue to
release security related updates for the kernel.  As this bug is not security
related, it is unlikely to be fixed in an update for FC4, and has been migrated
to FC5.

Please retest with Fedora Core 5.

Thank you.
Comment 4 Steve Wells 2006-09-16 22:19:31 EDT
Some additional information since this bug was first filed:

1) It appears Yum update was indeed responsible for downloading an "update" 
driver component that caused a conflict with the Dell driver that was 
previously installed.

2) This CPU1 IERR problem is a well known issue with Dell 2850, BIOS Revision 
prior to 05 and other systems running various versions of RedHat 8 and Fedora 
Core based OS.  It is primarily due to problems with the ATI Radeon driver.

3) In order to "fix" the problem be sure to have the more recent driver(s) 
installed.  In actuality, it appears the latest & greatest driver has 
problems.  The best working configuration was with their next to most recent 
driver (suprisingly, in this case, the one before the version that supposedly 
fixed the problem).

4) Using the latest driver requires the system be at runlevel 3 and to change 
xorg.conf to specify generic VESA vs. Radeon drivers.

5) As of 9/06 This issue still remains outstanding and continues to be engaged 
by Dell tech support.
Comment 5 Dave Jones 2006-10-16 14:19:13 EDT
A new kernel update has been released (Version: 2.6.18-1.2200.fc5)
based upon a new upstream kernel release.

Please retest against this new kernel, as a large number of patches
go into each upstream release, possibly including changes that
may address this problem.

This bug has been placed in NEEDINFO state.
Due to the large volume of inactive bugs in bugzilla, if this bug is
still in this state in two weeks time, it will be closed.

Should this bug still be relevant after this period, the reporter
can reopen the bug at any time. Any other users on the Cc: list
of this bug can request that the bug be reopened by adding a
comment to the bug.

In the last few updates, some users upgrading from FC4->FC5
have reported that installing a kernel update has left their
systems unbootable. If you have been affected by this problem
please check you only have one version of device-mapper & lvm2
installed.  See bug 207474 for further details.

If this bug is a problem preventing you from installing the
release this version is filed against, please see bug 169613.

If this bug has been fixed, but you are now experiencing a different
problem, please file a separate bug for the new problem.

Thank you.
Comment 6 Steve Wells 2006-10-30 00:09:07 EST
Dell Support has totally dropped this issue & acknowledged Dell 2850 + all 
other servers which use ATI onboard graphics support are incompatible with 
Fedora (4 or 5) and any other derivative of Red Hat Enterprise Linux +/- other 
versions, regardless of BIOS revision or Dell ATI Driver versions.
Comment 7 Matt Domsch 2006-11-21 18:21:29 EST
While it's true that Dell doesn't officially support FC{4,5} on our products, 
this still shouldn't happen, and sounds familiar to video issues we addressed 
in RHEL4 and upstream.  Need Robert to verify that the patches submitted to 
address those have been incorporated into FC6 at least.

Steve, have you tried with FC6?  If not, what's the latest kernel and xorg 
package versions you have tried that you see the failure in?
Comment 8 Matt Domsch 2006-11-21 18:21:55 EST
While it's true that Dell doesn't officially support FC{4,5} on our products, 
this still shouldn't happen, and sounds familiar to video issues we addressed 
in RHEL4 and upstream.  Need Robert to verify that the patches submitted to 
address those have been incorporated into FC6 at least.

Steve, have you tried with FC6?  If not, what's the latest kernel and xorg 
package versions you have tried that you see the failure in?
Comment 9 Steve Wells 2006-11-21 18:51:56 EST
Hi Matt,

Thank you for your follow-up here.  I've not gone back to reinstall FC5 or FC6 
and try those because, frankly, this problem chewed up so much time on our 
(+your/Dell's) time, had to give up after Dell support just dropped the ball 
the second time(declared my unresolved problem tickets "resolved" two 
different times and never followed up either time when a gal followed up by 
phone to see if had indeed been fixed and, of course, I'd told her NO! - but 
never received follow-up so just had to give up after 2nd failed handoff).  So 
we went to Gateway - which - as a still current but probably not too much 
longer - Dell stockholder, pained me greatly.<p>
So at this point this 2850 remains barely usable - it's now been relegated to 
status as a dev machine that crashes consistently though irregularly (it's 
currently been 1-1/2 days since the last crash).  I've not run yum update on 
the machine lately but could give that a shot, if you wish.  But based on last 
interactions with Dell support, the ATI drivers aren't even supposed to be in 
play (configured to use VESA), we've tried all the variations of Dell's ATI 
driver and, during the last iteration, things actually seemed to get worse 
(going from > weekly crashes to 2-3 days on average).  FYI - Other Dell's 
inhouse seemingly not affected.<p>
Please advise as to any additional info I can provide & your suggested course 
of action - it's no longer cost effective to take any time to reinstall FC5 on 
this machine (support advised to just return it for some partial refund, 
which, at this point, didn't seem cost effective, either - uggh) - but I'll be 
happy to yum update & play with the drivers + FC4 configuration again :)
<p>
Thanks!
Steve
Comment 10 Steve Wells 2006-11-21 18:55:45 EST
kernel: Linux version 2.6.17-1.2142_FC4smp
xorg-x11-rhel4_radeon_dell_server-6.8.1-23.DELL.3.EL.i386.rpm (fyi - this may 
not be latest but we've tried them all & as I recall the latest one actually 
made things worse at one point so we backed out everything and this is the one 
we ended up with).
Comment 11 Jon Stanley 2008-03-31 14:31:22 EDT
Removing NeedsRetesting from whiteboard so we can repurpose it.
Comment 12 Bug Zapper 2008-04-03 23:23:25 EDT
Fedora apologizes that these issues have not been resolved yet. We're
sorry it's taken so long for your bug to be properly triaged and acted
on. We appreciate the time you took to report this issue and want to
make sure no important bugs slip through the cracks.

If you're currently running a version of Fedora Core between 1 and 6,
please note that Fedora no longer maintains these releases. We strongly
encourage you to upgrade to a current Fedora release. In order to
refocus our efforts as a project we are flagging all of the open bugs
for releases which are no longer maintained and closing them.
http://fedoraproject.org/wiki/LifeCycle/EOL

If this bug is still open against Fedora Core 1 through 6, thirty days
from now, it will be closed 'WONTFIX'. If you can reporduce this bug in
the latest Fedora version, please change to the respective version. If
you are unable to do this, please add a comment to this bug requesting
the change.

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we are following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

And if you'd like to join the bug triage team to help make things
better, check out http://fedoraproject.org/wiki/BugZappers
Comment 13 Warren Togami 2008-04-04 11:25:22 EDT
This bug was never Fedora's fault.  CLOSING CANTFIX

Note You need to log in before you can comment on or make changes to this bug.