This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 20028 - mod_proxy causes apache to crash
mod_proxy causes apache to crash
Status: CLOSED DUPLICATE of bug 20800
Product: Red Hat Linux
Classification: Retired
Component: apache (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
Dale Lovelace
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-30 07:01 EST by Jim Nance
Modified: 2007-04-18 12:29 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-03 06:47:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
diff of my httpd.conf file with original (2.03 KB, patch)
2000-10-30 07:02 EST, Jim Nance
no flags Details | Diff

  None (edit)
Description Jim Nance 2000-10-30 07:01:27 EST
Trying to use the caching proxy server functionality of apache no longer
works, though it
did work with a vanilla 7.0 setup before I installed the various updates. 
When I try and
use the proxy server,  I get the following messages in my log:

[Mon Oct 30 06:06:02 2000] [notice] Apache/1.3.14 (Unix)  (Red-Hat/Linux)
mod_ssl/2.7.1 OpenSSL/0.9.5a mod_perl/1.24 configured -- resuming normal
operations
[Mon Oct 30 06:06:22 2000] [notice] child pid 7250 exit signal Segmentation
fault (11)
[Mon Oct 30 06:07:23 2000] [notice] child pid 7245 exit signal Segmentation
fault (11)
[Mon Oct 30 06:09:32 2000] [notice] child pid 7249 exit signal Segmentation
fault (11)

This system has been upgraded to use glibc-2.1.94-3 & apache-1.3.14-3,
though the
problem was present with apache-1.3.14-2 also.  I am fairly sure that
everthing was working
before any updates, though I dont know if it was the glibc or the apache
update that caused
the problem.

I recompiled apache with -g instead of -O2 so that I could debug this
problem.  Unfortunatly
everything works fine if apache is compiled with -g.

I am including a diff between my http.conf file and the one installed by
the RPM.

Thanks,

Jim


---------------
[root@bessie conf]# diff -u httpd.conf.orig httpd.conf    
--- httpd.conf.orig     Wed Oct 18 18:31:33 2000
+++ httpd.conf  Mon Oct 30 06:56:39 2000
@@ -233,7 +233,7 @@
 LoadModule anon_auth_module   modules/mod_auth_anon.so
 LoadModule db_auth_module     modules/mod_auth_db.so
 #LoadModule digest_module      modules/mod_digest.so
-#LoadModule proxy_module       modules/libproxy.so
+LoadModule proxy_module       modules/libproxy.so
 #LoadModule cern_meta_module   modules/mod_cern_meta.so
 LoadModule expires_module     modules/mod_expires.so
 LoadModule headers_module     modules/mod_headers.so
@@ -296,7 +296,7 @@
 AddModule mod_auth_anon.c
 AddModule mod_auth_db.c
 #AddModule mod_digest.c
-#AddModule mod_proxy.c
+AddModule mod_proxy.c
 #AddModule mod_cern_meta.c
 AddModule mod_expires.c
 AddModule mod_headers.c
@@ -396,6 +396,7 @@
 # anyway, and this will make redirections work in a sensible way.
 #
 #ServerName localhost
+ServerName tricia.dyndns.org
 
 #
 # DocumentRoot: The directory out of which you will serve your
@@ -970,14 +971,14 @@
 # Proxy Server directives. Uncomment the following lines to
 # enable the proxy server:
 #
-#<IfModule mod_proxy.c>
-#ProxyRequests On
+<IfModule mod_proxy.c>
+ProxyRequests On
 #
-#<Directory proxy:*>
-#    Order deny,allow
-#    Deny from all
-#    Allow from .your_domain.com
-#</Directory>
+<Directory proxy:*>
+    Order Deny,Allow
+    Deny from All
+    Allow from localhost 192.160.17.0/24 216.181.42.97
+</Directory>
 
 #
 # Enable/disable the handling of HTTP/1.1 "Via:" headers.
@@ -990,15 +991,15 @@
 # To enable the cache as well, edit and uncomment the following lines:
 # (no cacheing without CacheRoot)
 #
-#CacheRoot "/var/cache/httpd"
-#CacheSize 5
-#CacheGcInterval 4
-#CacheMaxExpire 24
-#CacheLastModifiedFactor 0.1
-#CacheDefaultExpire 1
-#NoCache a_domain.com another_domain.edu joes.garage_sale.com
+CacheRoot "/var/cache/httpd"
+CacheSize 5000
+CacheGcInterval 1
+CacheMaxExpire 72
+CacheLastModifiedFactor 0.1
+CacheDefaultExpire 1
+NoCache localhost 216.181.42.97
 
-#</IfModule>
+</IfModule>
 # End of proxy directives.
 
 ### Section 3: Virtual Hosts
Comment 1 Jim Nance 2000-10-30 07:02:27 EST
Created attachment 4754 [details]
diff of my httpd.conf file with original
Comment 2 Arenas Belon, Carlo Marcelo 2000-11-03 02:24:54 EST
Sig11 messages usually mean there is a Hardware Problem.
anyway i've been unable to reproduce it here.

as i have no mod_perl application to test on, i loaded mod_php (and all modules)
along with mod_perl and used it as a mail gateway with HORDE/IMP, no problem so
far.

IMHO mod_perl "should" be rebuilt in order to use the 1.3.14 headers but i see
no problem so far.

i guess it could be a mod_perl bug anyway, dropping mod_perl should be needed in
order to be sure.
Comment 3 Jim Nance 2000-11-03 06:47:52 EST
Not mod_perl, mod_proxy (ie using appache as a proxy server)
Comment 4 Arenas Belon, Carlo Marcelo 2000-11-24 00:34:51 EST

*** This bug has been marked as a duplicate of 20800 ***

Note You need to log in before you can comment on or make changes to this bug.