Bug 20800 - Bug with mod_proxy in new apache rpm
Summary: Bug with mod_proxy in new apache rpm
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: apache (Show other bugs)
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact: Dale Lovelace
URL:
Whiteboard:
Keywords:
: 20028 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-11-13 22:17 UTC by Christian Lepine
Modified: 2007-04-18 16:29 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-24 05:34:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Christian Lepine 2000-11-13 22:17:10 UTC
I have upgraded my redhat 7.0 installation with the new apache rpm but now 
the mod_proxy does not work any more.

Before the upgrade, the mod_proxy of apache was working fine.

I get a segmentation fault (11) in my /var/log/httpd/error_log when a 
client try to use the proxy configure with apache mod_proxy.

Christian Lepine
clepine@teccart.qc.ca

Comment 1 Tim Lundstrvm 2000-11-16 09:21:32 UTC
It worked with the apache packet submitted with the standard release of RH7.0.
It is the apache-1.3.14-3 packet that breaks apache. I'm having exactly the same
problem!

Comment 2 Nalin Dahyabhai 2000-11-17 19:30:01 UTC
Aaargh.  It appears that 1.3.12 *is* incompatible with 1.3.14, but only if both
have had the EAPI patch applied (EAPI functionality is used by mod_ssl). 
Tracing the error shows that it actually dies in mod_perl's proxy handler (at
least on my test box).  If you don't need mod_perl, try removing it  and see if
that works around it.  Errata packages are being prepped.

Comment 3 Arenas Belon, Carlo Marcelo 2000-11-24 05:34:48 UTC
*** Bug 20028 has been marked as a duplicate of this bug. ***

Comment 4 Nalin Dahyabhai 2001-01-11 19:38:14 UTC
Wow, those errata packages went out a while ago.  Time to close this.


Note You need to log in before you can comment on or make changes to this bug.