Bug 200324 - udev complains that a comment is too long to parse
udev complains that a comment is too long to parse
Status: CLOSED DUPLICATE of bug 200244
Product: Fedora
Classification: Fedora
Component: udev (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-26 16:39 EDT by Michal Jaegermann
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-07 08:47:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2006-07-26 16:39:24 EDT
Description of problem:

The following shows up on a startup:

Starting udev: udevd[399]: parse_file: line too long, rule skipped
'/etc/udev/rules.d/60-libsane.rules:772'

Luckily no harm done with skipping as line 772 from these rules
(sane-backends-1.0.18-1.fc6) happens to be a comment.  It is indeed
quite long, with 558 characters in it, but why an attempt to parse?

Or this should be charged to sane-backends?  The comment in question
could be easily split in a few lines.

OTOH udev documentation does not seem to mention that there are length
limits on rule lines.  That likely should be stated in an explicit
manner (even if it is a udev version dependent).

Version-Release number of selected component (if applicable):
udev-095-3
Comment 1 Harald Hoyer 2006-08-07 08:47:51 EDT

*** This bug has been marked as a duplicate of 200244 ***

Note You need to log in before you can comment on or make changes to this bug.