Bug 200244 - udev reports 'parse_file: line too long '.../60-libsane.rules : 772'
udev reports 'parse_file: line too long '.../60-libsane.rules : 772'
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: udev (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
: 200324 201845 201985 202148 202175 202937 (view as bug list)
Depends On:
Blocks: FC6Blocker
  Show dependency treegraph
 
Reported: 2006-07-26 10:30 EDT by Tom London
Modified: 2007-11-30 17:11 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-10 08:14:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tom London 2006-07-26 10:30:05 EDT
Description of problem:
On boot, udev reports line 772 of 60-libsane.rules is too long.
Appears to be a comment......

Version-Release number of selected component (if applicable):
sane-backends-1.0.18-1.fc6


How reproducible:
Every time


Steps to Reproduce:
1. boot
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Nils Philippsen 2006-07-28 05:26:10 EDT
Harald,

could udev maybe just ignore too long _comment_ lines like the one it complains
about in this case -- it's a large number of scanner models covered by one
vendor/product code? While I could just take the rules and cut off lines that
are too long (how long may they be anyway), I think in this case allowing such
long comments (udev won't be doing anything with them, will it?) would be
beneficial.
Comment 2 Kay Sievers 2006-08-02 10:37:42 EDT
Udev rule lines can be 512 chars long. Sounds like a _very_ long comment. :)
Comment 3 Nils Philippsen 2006-08-03 08:22:41 EDT
It is ;-). Still, it should be easy to read the line into that buffer, check the
buffer if it's a comment and only complain if it isn't.
Comment 4 drago01 2006-08-04 10:52:30 EDT
can the comment be splitted in multiple lines?
Comment 5 Harald Hoyer 2006-08-07 08:48:00 EDT
*** Bug 200324 has been marked as a duplicate of this bug. ***
Comment 6 Jeff Needle 2006-08-09 09:04:11 EDT
*** Bug 201845 has been marked as a duplicate of this bug. ***
Comment 7 Radek Bíba 2006-08-10 04:23:19 EDT
*** Bug 201985 has been marked as a duplicate of this bug. ***
Comment 8 Alan Cox 2006-08-10 07:45:38 EDT
Still present in FC6 t2
Comment 9 Nils Philippsen 2006-08-11 03:56:18 EDT
*** Bug 202148 has been marked as a duplicate of this bug. ***
Comment 10 Harald Hoyer 2006-08-11 08:52:04 EDT
*** Bug 202175 has been marked as a duplicate of this bug. ***
Comment 11 Harald Hoyer 2006-08-17 08:15:18 EDT
*** Bug 202937 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.