Bug 20034 - Kickstart broken?
Kickstart broken?
Status: CLOSED DUPLICATE of bug 18648
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-30 08:38 EST by Matthias Grimm
Modified: 2007-04-18 12:29 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-31 10:50:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda-dump (790 bytes, text/plain)
2000-10-30 08:40 EST, Matthias Grimm
no flags Details

  None (edit)
Description Matthias Grimm 2000-10-30 08:38:31 EST
Hi!

I created a ks.cfg with mkkickstart from a fresh-installed RH7.
downloaded the updated img-file for anaconda, put the ks.cfg on the boot-
disk, bootet from installation-floopy with the following commands:
linux updates ks=floppy
RH asks for the updates, and then pops up with the folowing error:

 Traceback (innermost last):
  File "/usr/bin/anaconda", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1030, in 
run
    rc = apply (step[1](), step[2])
  File "/var/tmp/anaconda-
7.0.1//usr/lib/anaconda/textw/partitioning_text.py", line 134, in __call__
    todo.lilo.allowLiloLocationConfig(todo.fstab)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/lilo.py", line 124, in 
allowLiloLocationConfig
    if bootDevice[0:2] == "md":
TypeError: unsliceable object

Local variables in innermost frame:
fstab: <fstab.NewtFstab instance at 8281c78>
self: <lilo.LiloConfiguration instance at 82803a0>
bootDevice: None

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>

here's my ks.cfg:

lang en_US


cdrom


keyboard "de-latin1"

zerombr yes
clearpart --all
part swap --size 204
install

mouse genericps/2 --emulthree

timezone Europe/Berlin

rootpw --iscrypted <deleted>
auth --useshadow

lilo --location mbr

%packages
filesystem
glibc
mktemp
libtermcap
anacron
mingetty
info
sed
fileutils
popt
sysklogd
which
modutils
initscripts
grep
at
autoconf
bc
bind-utils
bison
bzip2
cdecl
cpio
cproto
cracklib-dicts
ctags
cyrus-sasl
db2
dev
dhcpcd
diffutils
dump
eject
file
finger
flex
freetype
gcc
gcc-g77
gd-devel
gdbm
gettext
kernel-headers
gmp
gpm
groff
gzip
indent
inews
iproute
iputils
kbdconfig
kernel-utils
pwdb
sh-utils
kudzu
less
libjpeg-devel
libpng-devel
libstdc++-devel
libtiff
m4
libtool
lilo
textutils
linuxconf-devel
LPRng
lsof
lynx
mailx
MAKEDEV
man-pages
minicom
mkinitrd
mouseconfig
ncftp
ncurses-devel
netpbm
newt
nfs-utils
nmh
openldap
openssh
openssh-server
passwd
pciutils
pidentd
pmake
procmail
python
python-xmlrpc
raidtools
rdate
readline
rhn_register
rootfiles
rpm-build
rpm-python
rsync
rusers-server
sash
sendmail
setuptool
sharutils
slang-devel
slrn
strace
stunnel
SysVinit
tar
tcp_wrappers
tcsh
texinfo
timeconfig
tmpwatch
trn
urlview
util-linux
vim-minimal
yp-tools
ypserv
zlib-devel
openssl-perl
rpmdb-redhat
bind
libxml-devel
libxml
setup
basesystem
chkconfig
termcap
bash
apmd
ncurses
gawk
e2fsprogs
procps
logrotate
psmisc
vixie-cron
shadow-utils
arpwatch
ash
authconfig
automake
bdflush
binutils
byacc
bzip2-devel
console-tools
cpp
cracklib
crontabs
cvs
db1
db3
dev86
diffstat
dip
ed
elm
findutils
finger-server
fortune-mod
ftp
gcc-c++
gd
gdb
gdbm-devel
glib
glibc-devel
gnupg
gpm-devel
groff-perl
hdparm
indexhtml
ipchains
iptables
isapnptools
kernel
kernel-source
krb5-devel
pam
krb5-libs
kudzu-devel
libjpeg
libpng
libstdc++
libtermcap-devel
libtiff-devel
perl
libtool-libs
links
linuxconf
losetup
lrzsz
ltrace
mailcap
make
man
metamail
mkbootdisk
mount
mpage
ncompress
net-tools
netpbm-devel
newt-devel
njamd
ntsysv
openssl
openssh-clients
openssl-devel
patch
pciutils-devel
pine
portmap
pump
python-devel
quota
rcs
rdist
readline-devel
redhat-release
rmt
rpm
rpm-devel
rsh
rusers
rwho
screen
setserial
shapecfg
slang
slocate
stat
words
sysstat
talk
tcl
tcpdump
telnet
time
tin
traceroute
up2date
utempter
vim-common
whois
xinetd
ypbind
zlib
openssl-python
vim-enhanced
libxml10
rpmfind
mc
kgcc

%post

When I add this options:
part /boot --size 20 --asprimary
part / --size 200 

anaconda complains about (afaik)
'no root device set'
and reboots. :-(

Matthias
Comment 1 Matthias Grimm 2000-10-30 08:40:44 EST
Created attachment 4755 [details]
anaconda-dump
Comment 2 Michael Fulbright 2000-10-31 10:50:43 EST

*** This bug has been marked as a duplicate of 18648 ***

Note You need to log in before you can comment on or make changes to this bug.