Bug 18648 - Kickstart Support broken
Kickstart Support broken
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
: 19384 20034 27424 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-08 13:54 EDT by Dirk Nehring
Modified: 2007-04-18 12:29 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-19 18:59:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dirk Nehring 2000-10-08 13:54:16 EDT
Hello,

I have the following ks.cfg on a boot floppy:
--------------------8<---------------8<--------------
lang en_US
cdrom
keyboard de-latin1-nodeadkeys
lilo --location mbr
part / --onpart /dev/sda5
part /usr --onpart /dev/sda8
part /home --onpart /dev/sdc2
mouse
timezone MET
skipx
rootpw secret
auth --useshadow
#
%packages
@ Gnome Workstation
------------------8<---------8<------------------

When trying to boot the floppy with "linux ks=floppy", I got the following
error message after detecting my SCSI controller (btw, the disc is already
partitioned):

------------8<----------------8<-------------8<---
Traceback (innermost last):
  File "/usr/bin/anaconda", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1030, in
run
    rc = apply (step[1](), step[2])
  File
"/var/tmp/anaconda-7.0.1//usr/lib/anaconda/textw/partitioning_text.py", l
ine 134, in __call__
    todo.lilo.allowLiloLocationConfig(todo.fstab)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/lilo.py", line 124, in
allowLi
loLocationConfig
    if bootDevice[0:2] == "md":
TypeError: unsliceable object

Local variables in innermost frame:
fstab: <fstab.NewtFstab instance at 820c1f8>
self: <lilo.LiloConfiguration instance at 828c308>
bootDevice: None

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>
------------8<----------------8<-------------8<---

Seems to be a bug in the anaconda parser.
Comment 1 Michael Fulbright 2000-10-09 10:53:19 EDT
Would you give us the original partition state of the drive so we can try
reproducing this bug here?
Comment 2 Dirk Nehring 2000-10-09 13:49:19 EDT
Sure, this is the layout:

Disk /dev/sda: 255 heads, 63 sectors, 2231 cylinders
Units = cylinders of 16065 * 512 bytes

   Device Boot    Start       End    Blocks   Id  System
/dev/sda1   *         1       510   4096543+   b  Win95 FAT32
/dev/sda2           511      2231  13823932+   f  Win95 Ext'd (LBA)
/dev/sda5           511       772   2104483+  83  Linux
/dev/sda6           773      1686   7341673+   b  Win95 FAT32
/dev/sda7          1687      1735    393561   82  Linux swap
/dev/sda8          1736      2231   3984088+  83  Linux

Disk /dev/sdb: 255 heads, 63 sectors, 2231 cylinders
Units = cylinders of 16065 * 512 bytes

   Device Boot    Start       End    Blocks   Id  System
/dev/sdb1             1      2231  17920476    b  Win95 FAT32

Disk /dev/sdc: 134 heads, 62 sectors, 1019 cylinders
Units = cylinders of 8308 * 512 bytes

   Device Boot    Start       End    Blocks   Id  System
/dev/sdc1             1       505   2097739    b  Win95 FAT32
/dev/sdc2           506      1019   2135156   83  Linux

There is a current installation of Linux and Windows 98 on the computer, this
means lilo is already installed which 2 booting options.
Comment 3 Brent Fox 2000-10-10 20:10:08 EDT
The problem is that there is no value for bootDevice, so anaconda tracebacks
when you try to slice a value that is null.  fstab.py is where we are putting
values into bootDevice...except the problem is that mountList is empty for some
reason.  So, I'm trying to find out why mountList is empty.
Comment 4 Michael Fulbright 2000-10-31 10:50:40 EST
*** Bug 20034 has been marked as a duplicate of this bug. ***
Comment 5 Brock Organ 2001-01-11 11:31:33 EST
*** Bug 19384 has been marked as a duplicate of this bug. ***
Comment 6 vcrump 2001-01-19 20:45:33 EST
I also experienced this problem (#23433), but now have it working.  The
mkkickstart adds the clearpart and part swap lines, but no other part lines.
Apparently at least one part line is needed.  I wanted to do a kickstart @Server
installation, so I did it manually first, and then copied the partition table
info into part lines in my ks.cfg.  Now it works.
Comment 7 Michael Fulbright 2001-02-01 17:10:47 EST
Fixed in internal CVS.
Comment 8 Michael Fulbright 2001-02-13 23:04:15 EST
*** Bug 27424 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.