Bug 200487 - 2.16.17 kernels don't have sk98lin driver
2.16.17 kernels don't have sk98lin driver
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
: 199233 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-28 00:21 EDT by Darren Cook
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-29 02:11:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Darren Cook 2006-07-28 00:21:33 EDT
Description of problem:

I rebooted my FC4 server today for the first time in a while, but eth1 failed to
start. eth1 is a "Marvell Technology Group 88E8001 Gigabit Ethernet Controller".
kudzu -p also said sk98lin is the driver, Vendor 11ab (Sub: 1043), Device 4320
(Sub: 811a). 

"modprobe sk98lin" fails saying it does not exist.

After hunting in /lib/modules/ I found that the sk98lin driver is there (in
/kernel/drivers/net/sk98lin) in all kernels up until 2.6.16-1.2115_FC4. The
three 2.6.17 kernels do not have that directory.

I rebooted to 2.6.16-1.2115_FC4 and eth1 started fine, and everything else
started fine. (So this is high severity if you need something from the 2.6.17
kernels, low severity otherwise :-).


Version-Release number of selected component (if applicable):

2.6.17-1.2142_FC4.
Comment 1 Dave Jones 2006-07-29 02:11:17 EDT
sk98lin had a number of bugs, and was effectively abandoned by its upstream
maintainers.  As a result, a new driver was written from scratch which should
resolve the outstanding issues, and be a lot more maintainable long-term.

To switch to the new driver, edit your /etc/modprobe.conf
and change the 'sk98lin' to say 'skge'

You'll then need to recreate the initrd so that the right module ends up there.
The easiest way to do this is to remove and reinstall the newest kernel.
(or you can run mkinitrd by hand, read the manpage for info on the parameters)

I'm going to close this as notabug, as escaping that *awful* driver is a feature :-)
Comment 2 Dave Jones 2006-07-29 02:42:17 EDT
*** Bug 199233 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.