Bug 200542 - fails to find /dev/root after install
fails to find /dev/root after install
Status: CLOSED DUPLICATE of bug 196360
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
Depends On:
  Show dependency treegraph
Reported: 2006-07-28 11:31 EDT by Bill Peck
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-08-01 16:25:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Screen shot of the system not finding /dev/root (119.87 KB, image/jpeg)
2006-07-28 11:31 EDT, Bill Peck
no flags Details
kickstart used to install the system (11.09 KB, application/octet-stream)
2006-07-28 11:33 EDT, Bill Peck
no flags Details

  None (edit)
Description Bill Peck 2006-07-28 11:31:14 EDT
Description of problem:
anaconda installs the system fine (used nousbstorage for install) but fails to
find /dev/root upon bootup.  I've attached a screen shot of what is happening
and the kickstart file used.

Version-Release number of selected component (if applicable):

How reproducible:
Comment 1 Bill Peck 2006-07-28 11:31:15 EDT
Created attachment 133242 [details]
Screen shot of the system not finding /dev/root
Comment 2 Bill Peck 2006-07-28 11:33:07 EDT
Created attachment 133243 [details]
kickstart used to install the system
Comment 3 Jeremy Katz 2006-07-31 10:55:00 EDT
Hrmm... odd.  Can you get the system into rescue mode and then I can poke around
a little?
Comment 4 Bill Peck 2006-07-31 11:17:06 EDT
I will try and get a system up in rescue mode..  but I have another example of
the problem below.  You can see it having problems with the lock validator?

<Jul/30 09:53 pm>Loading cciss.ko module
<Jul/30 09:53 pm>HP CISS Driver (v 2.6.10)
<Jul/30 09:53 pm>ACPI: PCI Interrupt 0000:0a:01.0[A] -> GSI 72 (level, low) ->
IRQ 185
<Jul/30 09:53 pm>input: PS/2 Generic Mouse as /class/input/input1
<Jul/30 09:53 pm>cciss0: <0x3220> at PCI 0000:0a:01.0 IRQ 185 using DAC
<Jul/30 09:53 pm>      blocks= 71065440 block_size= 512
<Jul/30 09:53 pm>      heads= 255, sectors= 32, cylinders= 8709

<Jul/30 09:53 pm>INFO: trying to register non-static key.
<Jul/30 09:53 pm>the code is fine but needs lockdep annotation.
<Jul/30 09:53 pm>turning off the locking correctness validator.
<Jul/30 09:53 pm> [<c04051ea>] show_trace_log_lvl+0x54/0xfd
<Jul/30 09:53 pm> [<c04057a6>] show_trace+0xd/0x10
<Jul/30 09:53 pm> [<c04058bf>] dump_stack+0x19/0x1b
<Jul/30 09:53 pm> [<c043b1c0>] __lock_acquire+0xfd/0x997
<Jul/30 09:53 pm> [<c043bfcb>] lock_acquire+0x4b/0x6c
<Jul/30 09:53 pm> [<c0606e84>] _spin_lock_irq+0x1f/0x2e
<Jul/30 09:53 pm> [<c0604d02>] wait_for_completion+0x29/0x9e
<Jul/30 09:53 pm> [<f8865c36>] sendcmd_withirq+0x173/0x289 [cciss]
<Jul/30 09:53 pm> [<f8866c7c>] cciss_read_capacity+0x2f/0xa6 [cciss]
<Jul/30 09:53 pm> [<f8868c14>] cciss_revalidate+0xaa/0xfa [cciss]
<Jul/30 09:53 pm> [<c04a6abc>] rescan_partitions+0x6b/0x1e7
<Jul/30 09:53 pm> [<c0478e10>] do_open+0x2e9/0x3e4
<Jul/30 09:53 pm> [<c0478f7c>] blkdev_get+0x71/0x7c
<Jul/30 09:53 pm> [<c04a69ff>] register_disk+0x115/0x167
<Jul/30 09:53 pm> [<c04d8777>] add_disk+0x2e/0x3d
<Jul/30 09:53 pm> [<f886954d>] cciss_init_one+0x8e9/0xa58 [cciss]
<Jul/30 09:53 pm> [<c04ebfed>] pci_device_probe+0x39/0x5b
<Jul/30 09:53 pm> [<c054b252>] driver_probe_device+0x45/0x92
<Jul/30 09:53 pm> [<c054b37f>] __driver_attach+0x68/0x93
<Jul/30 09:53 pm> [<c054accb>] bus_for_each_dev+0x3a/0x5f
<Jul/30 09:53 pm> [<c054b1ad>] driver_attach+0x14/0x17
<Jul/30 09:53 pm> [<c054a9a2>] bus_add_driver+0x68/0x106
<Jul/30 09:53 pm> [<c054b628>] driver_register+0x78/0x7d
<Jul/30 09:53 pm> [<c04ec13e>] __pci_register_driver+0x4f/0x69
<Jul/30 09:53 pm> [<f881301c>] cciss_init+0x1c/0x1e [cciss]
<Jul/30 09:53 pm> [<c044231e>] sys_init_module+0x1679/0x1822
<Jul/30 09:53 pm> [<c0403faf>] syscall_call+0x7/0xb
<Jul/30 09:53 pm>      blocks= 71065440 block_size= 512
<Jul/30 09:53 pm>      heads= 255, sectors= 32, cylinders= 8709

<Jul/30 09:53 pm> cciss/c0d0: p1 p2 p3
<Jul/30 09:53 pm>Loading jbd.ko module
<Jul/30 09:53 pm>Loading ext3.ko module
<Jul/30 09:53 pm>Trying to resume from LABEL=SW-cciss/c0d0p3
<Jul/30 09:53 pm>Unable to access resume device (LABEL=SW-cciss/c0d0p3)
<Jul/30 09:53 pm>Creating root device.
<Jul/30 09:53 pm>Mounting root filesystem.
<Jul/30 09:53 pm>mount: could not find filesystem '/dev/root'
Comment 5 Peter Jones 2006-08-01 16:25:25 EDT

*** This bug has been marked as a duplicate of 196360 ***

Note You need to log in before you can comment on or make changes to this bug.