Bug 200571 - Abiword won't work without fribidi installed, doesn't pull in as dependency
Abiword won't work without fribidi installed, doesn't pull in as dependency
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: abiword (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Marc Maurer
Fedora Extras Quality Assurance
:
: 202127 (view as bug list)
Depends On:
Blocks: FE7Target
  Show dependency treegraph
 
Reported: 2006-07-28 14:10 EDT by Michael Knepher
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version: 2.4.5-3.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-13 16:59:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michael Knepher 2006-07-28 14:10:48 EDT
Description of problem:

Installed abiword from extras-devel. Start program. Try to type: app disappears.
Try to paste text from another app: app disappears. Try to open a document: app
disappears. Run from command-line always get this message: 

abiword: symbol lookup error: abiword: undefined symbol: fribidi_get_type

Check for fribidi, not installed, so I installed from devel repo. Abiword now works.

Version-Release number of selected component (if applicable):
abiword-2.4.5-2.fc6

How reproducible:
Always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Marc Maurer 2006-09-11 08:59:24 EDT
*** Bug 202127 has been marked as a duplicate of this bug. ***
Comment 2 Marc Maurer 2006-09-11 15:33:10 EDT
I'm puzzled how this could happen. The deps are automatically calculated. Could
you try with abiword-2.4.5-3.fc6 which I just built?
Comment 3 Jima 2007-02-13 16:59:22 EST
Since no one's addressed this bug, I just verified that the copy of abiword in
FC6 & devel does in fact depend on libfribidi.so.0, so I think we can call this
bug closed.

Note You need to log in before you can comment on or make changes to this bug.