Bug 200605 - /usr/libexec/frysk/funit crashes kernel
/usr/libexec/frysk/funit crashes kernel
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Moller
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-28 19:27 EDT by Andrew Cagney
Modified: 2007-11-30 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version: 2.6.17-1.2500.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-02 04:18:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of crash (35.11 KB, image/jpeg)
2006-07-31 16:23 EDT, Andrew Cagney
no flags Details
rotated and enlarged version. (83.12 KB, image/jpeg)
2006-07-31 16:36 EDT, Chris Moller
no flags Details
kernel trace from frysk crash (2.03 KB, text/plain)
2006-08-01 14:55 EDT, Chris Moller
no flags Details
console output from failing frysk "make check" (27.47 KB, text/plain)
2006-08-02 00:03 EDT, Chris Moller
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Sourceware 2959 None None None Never

  None (edit)
Description Andrew Cagney 2006-07-28 19:27:05 EDT
Description of problem:

cagney@towns$ /usr/libexec/frysk/funit frysk.sys.TestCallPtrace
Running testChildContinue(frysk.sys.TestCallPtrace) ...



Version-Release number of selected component (if applicable):

Linux towns.toronto.redhat.com 2.6.17-1.2449.fc6 #1 SMP Tue Jul 25 04:58:39 EDT
2006 i686 i686 i386 GNU/Linux

How reproducible:

100%

Steps to Reproduce:
1. install frysk rpm
2. run: /usr/libexec/frysk/funit frysk.sys.TestCallPtrace
3.
  
Actual results:

panic

Expected results:

no panic

Additional info:

do_wait
sys_wait4
sys_waitpid
syscall_call
ptrace_do_wait
<0>bug: write-lock lockup on cpu#0, funit/2054
show_trace_log_lvl
show_trace
dump_stack
_raw_write_lock
_write_lock_irq
do_exit
die
do_trap
do_invalid_op
error_code
Comment 1 Roland McGrath 2006-07-28 19:48:43 EDT
That info is not sufficient.  I need to see as much of the details in the panic
as possible.  Serial consoles are good.  A screen photo is sometimes adequate,
but it really has to be legible.  About the only part of the panic text that I
don't need to see is the "Modules linked in" list.
Comment 2 Andrew Cagney 2006-07-31 15:00:00 EDT
Chris, would you have access to a serial console so that the information roland
is asking for can be provided?

Roland, that's the stack backtrace.  I might now be able to get a snap, on
friday I did not have access to a camera.  And reproduction is trivial just run
the above command (it does not require a ui).
Comment 3 Chris Moller 2006-07-31 15:19:52 EDT
Not directly, but I was going to try an old PC, a null-modem cable, and minicom,
if that's still distributed.  I'll also need to install whatever kernel is
misbehaving and I'm afraid I'm going to have to install it in my development FC5
machine--a bit of a risk, I guess, but not too bad.
Comment 4 Andrew Cagney 2006-07-31 16:23:07 EDT
Created attachment 133351 [details]
Screenshot of crash
Comment 5 Chris Moller 2006-07-31 16:36:58 EDT
Created attachment 133356 [details]
rotated and enlarged version.

And here's a rotated/enlarged version that doesn't give me a crick in the neck
and a headache from squiting.
Comment 6 Roland McGrath 2006-07-31 17:26:58 EDT
Trade in that fish-eye lense for a serial cable! ;-)
That's a little more info, but still not all that much.
I'm trying to get a rawhide install working so I can reproduce this.
But unrelated rawhide problems are making it hard to get an install done.
Comment 7 Roland McGrath 2006-07-31 18:00:20 EDT
See also bug 200822
Comment 8 Roland McGrath 2006-08-01 13:32:56 EDT
Please try kernel-2.6.17-1.2488.fc6 and see if the problem persists there.
Comment 9 Chris Moller 2006-08-01 14:55:34 EDT
Created attachment 133428 [details]
kernel trace from frysk crash
Comment 10 Roland McGrath 2006-08-01 16:53:01 EDT
That crash is a new bug, not that same as bug 200822.
It's a simple fix, and it should be in the next kernel build.
Comment 11 Roland McGrath 2006-08-01 16:57:56 EDT
Please try the new 1.2500 build when it finishes.
Comment 12 Chris Moller 2006-08-02 00:03:36 EDT
Created attachment 133459 [details]
console output from failing frysk "make check"

First the good news: the test didn't kill the 1.2500 kernel--it worked fine
before, during, and after "make check."

The bad news is that the "make check" locked up--see the attachment.

I expect this means that /this/ bug can be closed--/usr/libexec/frysk/funit
frysk.sys.TestCallPtrace no longer kills the kernel--but another bug will just
take its place.

FWIW:

[0] (moller@hotbox) >l **/funit 					0:08:30

frysk-core/frysk/pkglibexecdir/funit*
[0] (moller@hotbox) >./frysk-core/frysk/pkglibexecdir/funit
frysk.sys.TestCallPtrace
Running testChildContinue(frysk.sys.TestCallPtrace) ...PASS
Running testAttach(frysk.sys.TestCallPtrace) ...PASS

Time: 0.003

OK (2 tests)

[0] (moller@hotbox) >DETACHED PROCESS: EXITING				0:09:39

FAIL
  junit.framework.AssertionFailedError

Time: 5.008
There was 1 failure:
1) testAttach(frysk.sys.TestCallPtrace)junit.framework.AssertionFailedError
   at frysk.sys.TestCallPtrace.testAttach(funit)
   at frysk.junit.Runner.<init>(funit)
   at funit.main(funit)

FAILURES!!!
Tests run: 2,  Failures: 1,  Errors: 0


[0] (moller@hotbox) >
Comment 13 Roland McGrath 2006-08-02 04:18:14 EDT
I'm closing this as fixed.  When you find from those frysk failures what the
kernel issues underlying are, they should get their own specific bugs filed.

Note You need to log in before you can comment on or make changes to this bug.