Bug 200822 - Hangs system when debugging firefox
Hangs system when debugging firefox
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Roland McGrath
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-31 16:31 EDT by Bill Nottingham
Modified: 2014-03-16 23:00 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-01 15:24:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2006-07-31 16:31:29 EDT
Description of problem:

firefox had been crashing recently for me, so I installed firefox-debuginfo,
and ran:

gdb /usr/lib/firefox-1.5.0.5/firefox-bin $(pidof firefox-bin)

After getting to the point where I could tell gdb to continue, the system locked.

Version-Release number of selected component (if applicable):
gdb-6.5-3.fc6
firefox-1.5.0.5-8
firefox-debuginfo-1.5.0.5-8
kernel-2.6.17-1.2462.fc6

How reproducible:

Twice so far, don't feel like trying again. :)

Steps to Reproduce:
1. install firefox-debuginfo
2. launch firefox
3. gdb /usr/lib/firefox-1.5.0.5/firefox-bin $(pidof firefox-bin)
  
Actual results:

System locks. Can't even ping it.

Expected results:

Not that.
Comment 1 Roland McGrath 2006-07-31 17:22:21 EDT
Probably a dup of bug 200605.
Comment 2 Bill Nottingham 2006-07-31 17:49:26 EDT
No panic, just a lock.

Hitting sysrq-p, then sysrq-t, yields:

...
[Thread -$BIGNUM (LWP 3349) exited]
[THread -$OTHER_BIGNUM (LWP 3350) exited]
BUG: write-lock lockup on CPU#0, gdb/3286, c0718a00 (Not tainted)
 [<c04051ea>] show_trace_log+lvl+0x54/0xfd
 [<c04057a6>] show_trace+0xd/0x10
 [<c04058bf>] dump_stack+0x19/0x1b
 [<c04e5186>] _raw_write_lock+0xd4/0xf6
 [<c060884a>] _write_lock_irq+0x26/0x2e
 [<c04260cf>] release_task+0x31/0x287
 [<c04537cf>] checK-noreap+0x2f/0x63
 [<c04539ab>] wake_quiescent+0x51/0xf0
 [<c0453c0e>] utrace_detach+0x67/0x78
 [<c042b7cb>] ptrace_detach+0x13/0x26
 [<c042c81b>] ptrace_do_wait+0x282/0x28c
 [<c0426b31>] do_wait+0x80c/0x9ad
 [<c0426cf8>] sys_wait4+0x26/0x2a
 [<c0426d0f>] sys_waitpid+0x13/0x15
 [<c0403faf>] syscall_call+0x7/0xb

Apologies for any typos.
Comment 3 Roland McGrath 2006-07-31 18:01:43 EDT
That call chain gives me a very strong idea what the problem might be.
I will look for the issue I suspect.
Comment 4 Roland McGrath 2006-08-01 13:25:15 EDT
Please try kernel-2.6.17-1.2488.fc6 and see if the problem persists there.
Comment 5 Bill Nottingham 2006-08-01 15:24:41 EDT
Works for me.

Note You need to log in before you can comment on or make changes to this bug.