Bug 200606 - xchat segfaulted.
xchat segfaulted.
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: xchat (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-28 19:39 EDT by Dave Jones
Modified: 2015-01-04 17:28 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-14 08:12:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Jones 2006-07-28 19:39:13 EDT
I noticed my machine I'd left logged into irc at the office fell off the net,
and on further investigation found no xchat running, but in its place, a shiny
core dump!

Backtrace is sketchy on details though:

#0  0x00000030ed5293aa in g_main_context_prepare () from /usr/lib64/libglib-2.0.so.0
(gdb) bt
#0  0x00000030ed5293aa in g_main_context_prepare () from /usr/lib64/libglib-2.0.so.0
#1  0x00000030ed529ae2 in g_main_context_check () from /usr/lib64/libglib-2.0.so.0
#2  0x00000030ed52a16d in g_main_loop_run () from /usr/lib64/libglib-2.0.so.0
#3  0x00002aaaaab41b09 in ?? ()
#4  0x0000000000949f90 in ?? ()
#5  0x0000000000949f90 in ?? ()
#6  0x0000000000949f90 in ?? ()
#7  0x0000000000000000 in ?? ()
Comment 1 Kevin Kofler 2007-07-10 08:35:54 EDT
Is this a duplicate of bug #188894? This is the sketchy FC5 xchat 2.6.0 
again...
Comment 2 Kevin Kofler 2007-07-12 12:41:56 EDT
Have you seen this happening with any XChat version other than 2.6.0 (in other 
words, anything other than FC5)? If this only ever happened with 2.6.0, I'll 
file this in the 2.6.0 D-Bus plugin unloading memory corruption bucket (aka bug 
#188894), but if this happens with other versions too, it's a separate bug 
worth investigating. Note that both earlier and later versions count because 
the upstream bug causing bug #188894 was introduced in 2.6.0 and fixed in 
2.6.1.
Comment 3 Dave Jones 2007-07-12 16:57:35 EDT
I stopped using xchat earlier this year, so I've not seen it happen since.
Comment 4 Kevin Kofler 2007-07-14 08:12:01 EDT
I think it doesn't make much sense to keep this open. If anyone sees this still 
happening in a current version, we can always reopen it.

Note You need to log in before you can comment on or make changes to this bug.