Bug 200652 - Macbook does not return from suspend
Macbook does not return from suspend
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pm-utils (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
:
: 199995 (view as bug list)
Depends On:
Blocks: 199990
  Show dependency treegraph
 
Reported: 2006-07-29 20:41 EDT by Wade Mealing
Modified: 2015-03-04 20:17 EST (History)
3 users (show)

See Also:
Fixed In Version: 2.6.17-1.2505.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-07 23:18:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wade Mealing 2006-07-29 20:41:10 EDT
Description of problem:

The macbook does not resume from suspend when the lid is closed or the command 

echo 'mem' > /sys/power/state

is issued.


Version-Release number of selected component (if applicable):

2.6.17-1.2439

How reproducible:

Every time.

Steps to Reproduce:
1. echo 'mem' > /sys/power/state
2. wait
3. open lid, press buttons
  
Actual results:

System to kick back into life

Expected results:

Screen remains black.

Additional info:

Additional information as it comes.  I might try and work this bug..
Comment 1 Dave Jones 2006-07-30 16:25:49 EDT
Nearly every laptop needs some sort of workaround on resume. Echo'ing stuff into
sysfs isn't going to make those workarounds happen. You should be using
pm-suspend instead.

If it resumes, but the screen remains off, but for eg capslock toggles the LED,
then it's usually a missing tweak to pm-utils.

If on resume the machine doesn't even respond to capslock however, it's a kernel
bug.
Comment 2 Wade Mealing 2006-07-30 19:29:39 EDT
Ok, machine responds to capslock.
Comment 3 Dave Jones 2006-07-31 19:30:49 EDT
ok, then it's likely some video reinitialisation magic missing from pm-utils.
Comment 4 Dave Jones 2006-07-31 19:37:01 EDT
*** Bug 199995 has been marked as a duplicate of this bug. ***
Comment 5 Wade Mealing 2006-08-01 02:15:11 EDT
Using pm-suspend

the screen goes blank, i see a flashing cursor in the top right. 

The light on the front of the macbook pulsates gently (this is sounding graphic
already ?)

I press the power key, i hear the dvd-rom flick into life, the backlight comes on.

Pressing the caps lock key, no light comes on or off.
Comment 6 Wade Mealing 2006-08-01 02:18:09 EDT
Note:

Each time pm-suspend has been used, I have been able to reproduce:

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=194610
Comment 7 Wade Mealing 2006-08-04 10:05:30 EDT
And.. now it suspends ! yay!

working in:
Linux localhost.localdomain 2.6.17-1.2505.fc6 #1 SMP Tue Aug 1 19:52:56 EDT 2006
i686 i686 i386 GNU/Linux
Comment 8 Christopher Blizzard 2006-08-04 10:23:07 EDT
But does it unsuspend? :)
Comment 9 Wade Mealing 2006-08-06 19:37:02 EDT
Going to suspend..

Suspended (networkmanager didnt auto reconnect to network...)

Resumed.. (I'm typing on it now ) 

Wade
Comment 10 Wade Mealing 2006-08-07 02:46:53 EDT
pm-suspend manually.. it suspends and returns

Wait 15 minutes on battery.. it suspends and returns

Comment 11 Wade Mealing 2006-08-07 03:15:18 EDT
Although... (queue dramatic music),

It seems IRQ #9 gets disabled, which means acpi events no longer work after suspend.

See: 
http://blogs.gnome.org/view/ryanl/2006/06/04/0
Comment 12 Christopher Blizzard 2006-08-07 08:28:51 EDT
That would explain a lot.  My machine has started suspending and resuming (yay!)
but after it does, a lot of things don't work.  Closing the lid won't suspend
the laptop.  gnome-power-manager also acts weirdly.  One step at a time.

Think we should open a new bug since at least we're returning from a suspend?
Comment 13 Wade Mealing 2006-08-07 23:16:37 EDT
Yes, will do so now.

Note You need to log in before you can comment on or make changes to this bug.