Bug 200691 - Intel ICH audio detected but no sound can be heard
Intel ICH audio detected but no sound can be heard
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Brian Maly
Brian Brock
bzcl34nup
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-30 20:46 EDT by Jen-Cheng Chen
Modified: 2008-05-06 12:10 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-06 12:10:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/root/scsound.log (11.45 KB, text/plain)
2006-07-30 20:46 EDT, Jen-Cheng Chen
no flags Details
Soundcard Detection Applet log (14.37 KB, text/plain)
2006-09-17 00:52 EDT, Alex Ezell
no flags Details
FC6 sound card detection log (41.80 KB, application/octet-stream)
2006-11-03 02:45 EST, Mike Rubel
no flags Details
This is the scsrun.log. (224 bytes, application/octet-stream)
2006-11-03 02:48 EST, Mike Rubel
no flags Details
lspci output (1.66 KB, text/plain)
2006-12-01 12:47 EST, Eric Boggess
no flags Details
scsconfig.log (45.37 KB, application/octet-stream)
2006-12-01 12:51 EST, Eric Boggess
no flags Details
scsrun.log (708 bytes, application/octet-stream)
2006-12-01 12:56 EST, Eric Boggess
no flags Details

  None (edit)
Description Jen-Cheng Chen 2006-07-30 20:46:15 EDT
Description of problem:
After installing FC5, the sound card was detected but no sound could be hear. I
have updated to kernel 2.6.27.2157 but the result it's the same

Version-Release number of selected component (if applicable):


How reproducible:
Just use any sound-related application or simply use the soundcard detect app

Steps to Reproduce:
1.
2.
3.
  
Actual results:
sound card detected but no sound could be hear

Expected results:
can hear sound

Additional info:
Comment 1 Jen-Cheng Chen 2006-07-30 20:46:15 EDT
Created attachment 133297 [details]
/root/scsound.log
Comment 2 Andreas Rexfort 2006-09-15 08:42:50 EDT
Same problem here with Intel 82801DB-Chip but only after update. Original FC5 
kernel works fine.
Comment 3 Alex Ezell 2006-09-17 00:52:20 EDT
Created attachment 136463 [details]
Soundcard Detection Applet log
Comment 4 Alex Ezell 2006-09-17 00:54:17 EDT
I attached my log as well. The kernel certainly knows the card is there, yet,
there is no sound.
Comment 5 Dave Jones 2006-10-16 20:42:19 EDT
A new kernel update has been released (Version: 2.6.18-1.2200.fc5)
based upon a new upstream kernel release.

Please retest against this new kernel, as a large number of patches
go into each upstream release, possibly including changes that
may address this problem.

This bug has been placed in NEEDINFO state.
Due to the large volume of inactive bugs in bugzilla, if this bug is
still in this state in two weeks time, it will be closed.

Should this bug still be relevant after this period, the reporter
can reopen the bug at any time. Any other users on the Cc: list
of this bug can request that the bug be reopened by adding a
comment to the bug.

In the last few updates, some users upgrading from FC4->FC5
have reported that installing a kernel update has left their
systems unbootable. If you have been affected by this problem
please check you only have one version of device-mapper & lvm2
installed.  See bug 207474 for further details.

If this bug is a problem preventing you from installing the
release this version is filed against, please see bug 169613.

If this bug has been fixed, but you are now experiencing a different
problem, please file a separate bug for the new problem.

Thank you.
Comment 6 Mike Rubel 2006-11-03 02:44:33 EST
I would like to report identical behavior in a new install of Fedora Core 6
(FC6).  The sound card is detected, snd-hda-intel is chosen, and a reasonable
amount of time passes while the test wav is supposed to be playing, but no sound
comes from the speakers or headphone.  I checked the mixer settings and they
seem reasonable.  Attaching the scsconfig.log and scsrun.log in a moment.

Sound worked under FC5, but because the system was preconfigured I do not know
whether it would have worked with a default FC5 install, or if subsequent
changes were made.
Comment 7 Mike Rubel 2006-11-03 02:45:57 EST
Created attachment 140220 [details]
FC6 sound card detection log
Comment 8 Mike Rubel 2006-11-03 02:48:07 EST
Created attachment 140221 [details]
This is the scsrun.log.
Comment 9 John W. Linville 2006-11-03 09:43:46 EST
I'm not sure what you mean by "mixer settings...seem reasonable".  Have you 
tried unmuting everything AND turning all volume controls to maximum?

Often times hardware manufactures choose strange wiring configurations for 
their audio hardware.  Unless/until the kernel is aware of that specific box, 
you get problems like volume and mute controls that map to the wrong input or 
output.  My guess is that is the case here.

Please try unmuting and setting max volume for all inputs and outputs, then 
trying to play something again.  Also, please attach the output of 
running "lspci -n"...thanks! 
Comment 10 Mike Rubel 2006-11-05 03:23:57 EST
John, thanks for getting back to me so quickly.

I'm no expert on alsa, but based on what I've been reading on the web:

# # alsaunmute 0 -v -s 100
Card 0 Driver snd_hda_intel Volume 100%...
Unmuting ...
Play. Volume pcm(0) to 255
Play. Volume pcm(1) to 255
Play. Switch front(0) to 1
Play. Switch front(1) to 1
Play. Switch cd(0) to 1
Play. Volume cd(0) to 23
Play. Switch cd(1) to 1
Play. Volume cd(1) to 23
Play. Switch mic(0) to 0
Play. Volume mic(0) to 0
Play. Switch mic(1) to 0
Play. Volume mic(1) to 0
Unmuting snd_hda_intel...

Which leaves:

$ amixer
Simple mixer control 'PCM',0
  Capabilities: pvolume
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 255
  Mono:
  Front Left: Playback 255 [100%]
  Front Right: Playback 255 [100%]
Simple mixer control 'Front',0
  Capabilities: pswitch
  Playback channels: Front Left - Front Right
  Mono:
  Front Left: Playback [on]
  Front Right: Playback [on]
Simple mixer control 'CD',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 23
  Mono:
  Front Left: Playback 23 [100%] [on]
  Front Right: Playback 23 [100%] [on]
Simple mixer control 'Mic',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 23
  Mono:
  Front Left: Playback 0 [0%] [off]
  Front Right: Playback 0 [0%] [off]
Simple mixer control 'IEC958',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'Capture',0
  Capabilities: cvolume cswitch
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 13
  Front Left: Capture 0 [0%] [on]
  Front Right: Capture 0 [0%] [on]
Simple mixer control 'Input Source',0
  Capabilities: enum
  Items: 'Mic' 'CD'
  Item0: 'Mic'

This is a laptop, and to the best of my knowledge there are no other volume
adjustments.

Still, though, I can play a wav in the sense that time elapses while the sound
is supposed to be playing, but I only hear silence.

# /sbin/lspci -n
00:00.0 0600: 8086:27a0 (rev 03)
00:02.0 0300: 8086:27a2 (rev 03)
00:02.1 0380: 8086:27a6 (rev 03)
00:1b.0 0403: 8086:27d8 (rev 02)
00:1c.0 0604: 8086:27d0 (rev 02)
00:1c.1 0604: 8086:27d2 (rev 02)
00:1c.2 0604: 8086:27d4 (rev 02)
00:1d.0 0c03: 8086:27c8 (rev 02)
00:1d.1 0c03: 8086:27c9 (rev 02)
00:1d.2 0c03: 8086:27ca (rev 02)
00:1d.3 0c03: 8086:27cb (rev 02)
00:1d.7 0c03: 8086:27cc (rev 02)
00:1e.0 0604: 8086:2448 (rev e2)
00:1f.0 0601: 8086:27b9 (rev 02)
00:1f.2 0101: 8086:27c4 (rev 02)
00:1f.3 0c05: 8086:27da (rev 02)
01:0a.0 0c00: 1217:00f7 (rev 02)
01:0a.2 0805: 1217:7120 (rev 01)
01:0a.3 0180: 1217:7130 (rev 01)
03:00.0 0280: 8086:4222 (rev 02)
07:00.0 0200: 11ab:4362 (rev 20)

Do you think this might be significant?:

# dmesg | grep ALC
hda_codec: Unknown model for ALC861, trying auto-probe from BIOS...

I was searching around online, and noticed this thread on the alsa bugtrack. 
Think it might be relevant?:

https://bugtrack.alsa-project.org/alsa-bug/view.php?id=2174

Thanks *very* much!
Comment 11 Eric Boggess 2006-12-01 12:47:11 EST
Created attachment 142587 [details]
lspci output

I just installed fc6 on my Dell Latitude D800 and I am having the same problem
with my sound card: Multimedia audio controller: Intel Corporation
82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller (rev 01).
Comment 12 Eric Boggess 2006-12-01 12:51:39 EST
Created attachment 142590 [details]
scsconfig.log

scsconfig.log for Dell Latitud D800 with Intel 82801DB/DBL/DBM
(ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller (rev 01) sound card using Fedora
Core 6
Comment 13 Eric Boggess 2006-12-01 12:56:37 EST
Created attachment 142593 [details]
scsrun.log

scsrun.log for a Dell Latitude D800 with an Intel 82801DB/DBL/DBM
(ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller (rev 01) sound card running Fedora
Core 6
Comment 14 Brian Maly 2008-01-16 13:03:23 EST
Looks like we may need support for the ALC861 codec to resolve this issue. 
Comment 15 Bug Zapper 2008-04-03 23:24:35 EDT
Fedora apologizes that these issues have not been resolved yet. We're
sorry it's taken so long for your bug to be properly triaged and acted
on. We appreciate the time you took to report this issue and want to
make sure no important bugs slip through the cracks.

If you're currently running a version of Fedora Core between 1 and 6,
please note that Fedora no longer maintains these releases. We strongly
encourage you to upgrade to a current Fedora release. In order to
refocus our efforts as a project we are flagging all of the open bugs
for releases which are no longer maintained and closing them.
http://fedoraproject.org/wiki/LifeCycle/EOL

If this bug is still open against Fedora Core 1 through 6, thirty days
from now, it will be closed 'WONTFIX'. If you can reporduce this bug in
the latest Fedora version, please change to the respective version. If
you are unable to do this, please add a comment to this bug requesting
the change.

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we are following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

And if you'd like to join the bug triage team to help make things
better, check out http://fedoraproject.org/wiki/BugZappers
Comment 16 Bug Zapper 2008-05-06 12:10:42 EDT
This bug is open for a Fedora version that is no longer maintained and
will not be fixed by Fedora. Therefore we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen thus bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.