Bug 200719 - Pirut crash when this one is starting
Pirut crash when this one is starting
Status: CLOSED DUPLICATE of bug 200515
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
i386 Linux
high Severity high
: ---
: ---
Assigned To: Jeremy Katz
Depends On:
  Show dependency treegraph
Reported: 2006-07-31 06:09 EDT by Damien Durand
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-07-31 07:37:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Damien Durand 2006-07-31 06:09:42 EDT
Description of problem:

Problem is really simple, just launch pirut and this one crash.

Steps to Reproduce:
1. Start pirut
2. Enter your root password
3. This one crash
stack trace:

Component: Software Manager
Summary: TBe50a4c40 GroupSelector.py:329:_populateGroups:NameError: global name
'get_pix' is not defined

Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/pirut/GroupSelector.py", line 318, in
    self._populateGroups(cat.groups, fbpix)
  File "/usr/lib/python2.4/site-packages/pirut/GroupSelector.py", line 329, in
    pix = get_pix(fn)
NameError: global name 'get_pix' is not defined

Local variables in innermost frame:
grp: GNOME Desktop Environment
defaultpix: <gtk.gdk.Pixbuf object (GdkPixbuf) at 0xb6c8389c>
self: <pirut.GroupSelector.GroupSelector instance at 0xb70b282c>
s: <span size="large" weight="bold">Environnement de bureau GNOME</span>
groups: ['gnome-desktop', 'xfce-desktop', 'kde-desktop']
grps: [<yum.comps.Group object at 0xb70d3e6c>, <yum.comps.Group object at
0xb706cc4c>, <yum.comps.Group object at 0xb706caec>]
fn: /usr/share/pixmaps/comps/gnome-desktop.png
Comment 1 Jeremy Katz 2006-07-31 07:37:03 EDT

*** This bug has been marked as a duplicate of 200515 ***

Note You need to log in before you can comment on or make changes to this bug.