Bug 200728 - [si_LK] ZWJ support, sinhala not rendered properly
Summary: [si_LK] ZWJ support, sinhala not rendered properly
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact:
URL:
Whiteboard:
Keywords: i18n
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-07-31 12:24 UTC by A S Alam
Modified: 2013-07-03 00:39 UTC (History)
3 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2006-08-09 10:04:58 UTC


Attachments (Terms of Use)
picture (49.09 KB, image/png)
2006-07-31 12:47 UTC, Caolan McNamara
no flags Details
part of the puzzle (703 bytes, patch)
2006-07-31 19:41 UTC, Caolan McNamara
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 68047 None None None Never
OpenOffice.org 68048 None None None Never

Description A S Alam 2006-07-31 12:24:22 UTC
+++ This bug was initially created as a clone of Bug #200727 +++

Description of problem:
when try to input for Sinhala Language, then failed to render properly

Version-Release number of selected component (if applicable):
openoffice.org-core-2.0.3-7.6

How reproducible:


Steps to Reproduce:
1. Open  oowriter
2. goto ny text input area)
3. for input,
please install scim-sinhala (from rawhide) and press following keys

4) "kRoo"
Ctrl+Space to activative and Deactivate Input method

  
Actual results:
rendering is broken

Expected results:
Rendering should like Gedit

Additional info:
test same input for gedit (à¶à·âරà·)
Font package: font-sinhala

Comment 1 Caolan McNamara 2006-07-31 12:47:02 UTC
Created attachment 133315 [details]
picture

so this is what you get, i.e. gedit is correct, OOo shows something when you
type, but it's wrong, and if I paste into writer I get yet another sequence of
glyphs.

I bet that this is an icu problem from icu's perspective.

Comment 2 Caolan McNamara 2006-07-31 12:50:57 UTC
So this looks to me like that icu doesn't know about the correct combining
characters characteristics for sinhala

Comment 3 A S Alam 2006-07-31 12:55:42 UTC
yes, there is long list of those type of combination. 
(with 0DCA/0DBB+200D+<SPACE> characters), which are not properly Rendered

Comment 4 A S Alam 2006-07-31 12:59:22 UTC
Adding si_LK expert for more detail

Comment 5 Caolan McNamara 2006-07-31 15:32:10 UTC
let me examine icu 3.6d01 release candidate, there seems to have been some
possibly relevent work there

Comment 6 Caolan McNamara 2006-07-31 17:33:12 UTC
Looks like it's the ZWJ 0x200D which isn't supported by the OOo+ICU chain, still
exists in icu 3.6 at the moment

Comment 7 Caolan McNamara 2006-07-31 19:41:33 UTC
Created attachment 133346 [details]
part of the puzzle

At least this is required, maybe more. This allows me to load a document
containin the above sequence and render it correctly. Need to do some more
examination to see if it's the complete story.

Comment 8 Caolan McNamara 2006-08-01 11:04:10 UTC
Ah, the input method still cannot enter the correct sequence because OOo doesn't
implement the retrieve_surrounding signal to give the context which scim-sinhala
needs to know about to give the same sequence as gedit. Tricky, very tricky.
also need for thai I would expect

Comment 9 Caolan McNamara 2006-08-01 15:38:31 UTC
heh, so I cooked up a lunatic implementation based around the accessibility
interface which seems like it will do the right thing. Fix checked in, will be
in next respin

Comment 11 Caolan McNamara 2006-08-02 07:58:35 UTC
caolan->aalam: I don't see the pictures referenced in the .html to be sure they
are currently rendered correctly, but they all list the dread 0x200D ZWJ, so
they would all fall into the category of problem which attachment 1 [details] addresses.


Note You need to log in before you can comment on or make changes to this bug.