Bug 2008403 - Bump to latest available 1.21.5 k8s
Summary: Bump to latest available 1.21.5 k8s
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: kube-apiserver
Version: 4.8
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.8.z
Assignee: Josef Karasek
QA Contact: Ke Wang
URL:
Whiteboard:
Depends On: 2008827
Blocks: 2008508
TreeView+ depends on / blocked
 
Reported: 2021-09-28 07:21 UTC by Josef Karasek
Modified: 2021-11-23 11:33 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Release Note
Doc Text:
This fix contains the following changes coming from updated version of kubernetes up to v1.21.5: Changelog for v1.21.5: https://github.com/kubernetes/kubernetes/blob/release-1.21/CHANGELOG/CHANGELOG-1.21.md#v1215
Clone Of:
Environment:
Last Closed: 2021-11-23 11:33:27 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift kubernetes pull 981 0 None open Bug 2008403: Rebase v1.21.5 2021-10-26 14:33:18 UTC
Red Hat Product Errata RHBA-2021:4716 0 None None None 2021-11-23 11:33:50 UTC

Description Josef Karasek 2021-09-28 07:21:55 UTC
This is bringing in the following changes:

Changelog for v1.21.5: https://github.com/kubernetes/kubernetes/blob/release-1.21/CHANGELOG/CHANGELOG-1.21.md#v1215

Comment 1 Dhriti Shikhar 2021-09-28 08:42:56 UTC
Current PR bringing in kubernetes v1.21.5 is https://github.com/openshift/kubernetes/pull/981

This is bringing in the following changes:

Changelog for v1.21.5: https://github.com/kubernetes/kubernetes/blob/release-1.21/CHANGELOG/CHANGELOG-1.21.md#v1215

Comment 6 Ke Wang 2021-11-15 03:52:35 UTC
Verification steps,

$ oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.8.0-0.nightly-2021-11-13-150944   True        False         5m30s   Cluster version is 4.8.0-0.nightly-2021-11-13-150944

$ oc get no
NAME                                         STATUS   ROLES    AGE   VERSION
ip-10-0-150-120.us-west-2.compute.internal   Ready    worker   24m   v1.21.5+9e8f924
ip-10-0-151-0.us-west-2.compute.internal     Ready    master   31m   v1.21.5+9e8f924
ip-10-0-151-56.us-west-2.compute.internal    Ready    master   31m   v1.21.5+9e8f924
ip-10-0-189-155.us-west-2.compute.internal   Ready    worker   24m   v1.21.5+9e8f924
ip-10-0-229-104.us-west-2.compute.internal   Ready    master   31m   v1.21.5+9e8f924
ip-10-0-236-165.us-west-2.compute.internal   Ready    worker   24m   v1.21.5+9e8f924

$ oc get co/kube-apiserver -o yaml | grep -A1 '\- name: kube-apiserver'
  - name: kube-apiserver
    version: 1.21.5

$ oc version
Client Version: 4.10.0-0.nightly-2021-10-16-173656
Server Version: 4.8.0-0.nightly-2021-11-13-150944
Kubernetes Version: v1.21.5+9e8f924

See above, Kubernetes is updated to 1.21.5. As for functional tests, have to rely on QE's daily schedule regression tests. During the tests, if there will be issue hit on any component related to the rebase, separate bug should be filed. Move the bug VERIFIED.

Comment 9 errata-xmlrpc 2021-11-23 11:33:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.8.21 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:4716


Note You need to log in before you can comment on or make changes to this bug.