Bug 2008508 - Bump to latest available 1.20.11 k8s
Summary: Bump to latest available 1.20.11 k8s
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: kube-apiserver
Version: 4.7
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.7.z
Assignee: Josef Karasek
QA Contact: Ke Wang
URL:
Whiteboard:
Depends On: 2008403
Blocks: 2021468
TreeView+ depends on / blocked
 
Reported: 2021-09-28 12:09 UTC by Josef Karasek
Modified: 2021-12-01 13:35 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
This fix contains the following changes coming from updated version of kubernetes up to v1.20.11: Changelog for v1.20.11: https://github.com/kubernetes/kubernetes/blob/master/CHANGELOG/CHANGELOG-1.20.md#v12011
Clone Of:
Environment:
Last Closed: 2021-12-01 13:35:22 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift kubernetes pull 982 0 None open Bug 2008508: Rebase v1.20.11 2021-10-26 14:40:42 UTC
Red Hat Product Errata RHBA-2021:4802 0 None None None 2021-12-01 13:35:43 UTC

Description Josef Karasek 2021-09-28 12:09:35 UTC
This is bringing in the following changes:

Changelog for v1.20.11: https://github.com/kubernetes/kubernetes/blob/master/CHANGELOG/CHANGELOG-1.20.md#v12011

Comment 1 Josef Karasek 2021-09-28 12:13:07 UTC
Current PR bringing in kubernetes v1.20.11 is https://github.com/openshift/kubernetes/pull/982

This is bringing in the following changes:

Changelog for v1.20.11: https://github.com/kubernetes/kubernetes/blob/master/CHANGELOG/CHANGELOG-1.20.md#v12011

Comment 2 Michal Fojtik 2021-09-28 12:30:06 UTC
** A NOTE ABOUT USING URGENT **

This BZ has been set to urgent severity and priority. When a BZ is marked urgent priority Engineers are asked to stop whatever they are doing, putting everything else on hold.
Please be prepared to have reasonable justification ready to discuss, and ensure your own and engineering management are aware and agree this BZ is urgent. Keep in mind, urgent bugs are very expensive and have maximal management visibility.

NOTE: This bug was automatically assigned to an engineering manager with the severity reset to *unspecified* until the emergency is vetted and confirmed. Please do not manually override the severity.

** INFORMATION REQUIRED **

Please answer these questions before escalation to engineering:

1. Has a link to must-gather output been provided in this BZ? We cannot work without. If must-gather fails to run, attach all relevant logs and provide the error message of must-gather.
2. Give the output of "oc get clusteroperators -o yaml".
3. In case of degraded/unavailable operators, have all their logs and the logs of the operands been analyzed [yes/no]
4. List the top 5 relevant errors from the logs of the operators and operands in (3).
5. Order the list of degraded/unavailable operators according to which is likely the cause of the failure of the other, root-cause at the top.
6. Explain why (5) is likely the right order and list the information used for that assessment.
7. Explain why Engineering is necessary to make progress.

Comment 5 Ke Wang 2021-11-12 11:33:56 UTC
Checked with OCP 4.7 latest nightly payload 4.7.0-0.nightly-2021-11-08-025909,

$ oc login --token=<Token> --server=https://api.ci.l2s4.p1.openshiftapps.com:6443

$ docker login -u wangke19 -p $(oc whoami -t) registry.ci.openshift.org

$ oc adm release info --commits registry.ci.openshift.org/ocp/release:4.7.0-0.nightly-2021-11-08-025909 | grep kubernetes
hyperkube                                      https://github.com/openshift/kubernetes                                     bbbc0799c02950831c42c7a2ab0a04594b854d4a

$ git log --date local --pretty="%h %an %cd - %s" bbbc079 | grep 'jose.*#982 '
No results found

Have to wait for next payload landed the PR.

Comment 7 Ke Wang 2021-11-16 02:35:52 UTC
$ oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.7.0-0.nightly-2021-11-15-192525   True        False         6m7s    Cluster version is 4.7.0-0.nightly-2021-11-15-192525

$ oc get no
NAME                                         STATUS   ROLES    AGE   VERSION
ip-10-0-134-248.us-east-2.compute.internal   Ready    master   27m   v1.20.11+b5f9544
ip-10-0-177-74.us-east-2.compute.internal    Ready    worker   23m   v1.20.11+b5f9544
ip-10-0-181-67.us-east-2.compute.internal    Ready    worker   20m   v1.20.11+b5f9544
ip-10-0-191-174.us-east-2.compute.internal   Ready    master   28m   v1.20.11+b5f9544
ip-10-0-198-210.us-east-2.compute.internal   Ready    master   28m   v1.20.11+b5f9544
ip-10-0-242-49.us-east-2.compute.internal    Ready    worker   22m   v1.20.11+b5f9544

$ oc get co/kube-apiserver -o yaml | grep -A1 '\- name: kube-apiserver'
  - name: kube-apiserver
    version: 1.20.11

$ oc version
Client Version: 4.10.0-0.nightly-2021-10-16-173656
Server Version: 4.7.0-0.nightly-2021-11-15-192525
Kubernetes Version: v1.20.11+b5f9544

From above, Kubernetes is updated to 1.20.11. As for functional tests, have to rely on QE's daily schedule regression tests. During the tests, if there will be issue hit on any component related to the rebase, separate bug should be filed. Move the bug VERIFIED.

Comment 10 errata-xmlrpc 2021-12-01 13:35:22 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.7.38 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:4802


Note You need to log in before you can comment on or make changes to this bug.