Bug 2008717 - JQ Mess Up with Big Integer
Summary: JQ Mess Up with Big Integer
Keywords:
Status: CLOSED ERRATA
Alias: None
Deadline: 2021-11-09
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: jq
Version: 8.0
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: rc
: ---
Assignee: Tomas Halman
QA Contact: Scott Poore
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-09-29 01:17 UTC by Yanping Li
Modified: 2022-05-10 14:01 UTC (History)
3 users (show)

Fixed In Version: jq-1.6-3.el8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-05-10 13:38:07 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Issue Tracker RHELPLAN-98403 0 None None None 2021-09-29 01:20:17 UTC
Red Hat Issue Tracker SSSD-3965 0 None None None 2021-10-06 10:05:41 UTC
Red Hat Product Errata RHBA-2022:1788 0 None None None 2022-05-10 13:38:09 UTC

Description Yanping Li 2021-09-29 01:17:13 UTC
Description of problem:

The current version has a terrible bug that messes up any big integer number.
See error report and the fix: https://github.com/stedolan/jq/pull/1752


Version-Release number of selected component (if applicable):

The latest version from github already has the issue fixed since Oct 22, 2019. Please pull the latest version!!


How reproducible:


Steps to Reproduce:
$ echo '{"a":9011153322235679}' | jq '.a'


Actual results:
9011153322235680

Expected results:
9011153322235679

Additional info:

Comment 1 Davide Cavalca 2021-09-29 15:44:09 UTC
Looks like this impacts Fedora as well, I can repro it on Fedora 34, 35 and on Rawhide. Filed https://bugzilla.redhat.com/show_bug.cgi?id=2008979 to track it there.

Comment 2 Davide Cavalca 2021-09-29 15:58:23 UTC
And this also repros on CentOS Stream 9 so filed https://bugzilla.redhat.com/show_bug.cgi?id=2008983 for that

Comment 3 Davide Cavalca 2021-09-29 19:46:40 UTC
We have backported the Fedora fix for this (https://src.fedoraproject.org/rpms/jq/pull-request/4) in https://cbs.centos.org/koji/buildinfo?buildID=35237 for Hyperscale, you can see the branch here in case it helps: https://git.centos.org/rpms/jq/c/f116ff5a7250bc9a9a6d42b7670aff28a99755c8?branch=c8s-sig-hyperscale

Comment 9 Scott Poore 2021-10-15 19:50:55 UTC
Verified

Version ::

jq-1.6-3.el8.x86_64

Results ::

[root@rhel8 ~]# echo '{"a":9011153322235679}' | jq '.a'
9011153322235679

Comment 11 errata-xmlrpc 2022-05-10 13:38:07 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (jq bug fix and enhancement update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2022:1788


Note You need to log in before you can comment on or make changes to this bug.