Bug 2008979 - jq issue with integer handling logic [fedora]
Summary: jq issue with integer handling logic [fedora]
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: jq
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Haïkel Guémar
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException
Depends On:
Blocks: F35FinalFreezeException
TreeView+ depends on / blocked
 
Reported: 2021-09-29 15:43 UTC by Davide Cavalca
Modified: 2021-10-16 01:14 UTC (History)
7 users (show)

Fixed In Version: jq-1.6-10.fc35
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-10-16 01:14:44 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Davide Cavalca 2021-09-29 15:43:54 UTC
Description of problem:
The current version has a bug in the integer handling logic that produces incorrect results for big integer number. See the upstream error report and the fix: https://github.com/stedolan/jq/pull/1752

This was originally reported in https://bugzilla.redhat.com/show_bug.cgi?id=2008717 for RHEL 8, but it impacts Fedora just as well. I've verified this affects jq in Fedora 34, 35 and Rawhide.

Version-Release number of selected component (if applicable):
jq-1.6-9.fc36

How reproducible:
always

Steps to Reproduce:
$ echo '{"a":9011153322235679}' | jq '.a'


Actual results:
9011153322235680

Expected results:
9011153322235679

Comment 1 Davide Cavalca 2021-09-29 17:47:50 UTC
Put up https://src.fedoraproject.org/rpms/jq/pull-request/4 with a backport of the upstream fix

Comment 2 Fedora Blocker Bugs Application 2021-10-13 22:59:09 UTC
Proposed as a Freeze Exception for 35-final by Fedora user dcavalca using the blocker tracking app because:

 This is a user-facing issue in a very commonly used tool that can result in incorrect data being produced. There's already a fix attached to the bug. See  https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/thread/5O2FW2RUIK7LO54NDKKPCX55AAA2OVC4/ for additional context.

Comment 3 Adam Williamson 2021-10-14 23:15:35 UTC
+3 in https://pagure.io/fedora-qa/blocker-review/issue/544 , marking accepted.

Comment 4 Fedora Update System 2021-10-15 02:11:35 UTC
FEDORA-2021-cdc2cb4c5a has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2021-cdc2cb4c5a

Comment 5 Fedora Update System 2021-10-15 02:11:36 UTC
FEDORA-2021-f727442f9b has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2021-f727442f9b

Comment 6 Fedora Update System 2021-10-15 04:51:45 UTC
FEDORA-2021-ab44a1d0c9 has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2021-ab44a1d0c9

Comment 7 Fedora Update System 2021-10-15 18:54:01 UTC
FEDORA-2021-f727442f9b has been pushed to the Fedora 33 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 8 Fedora Update System 2021-10-15 19:22:40 UTC
FEDORA-2021-cdc2cb4c5a has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 9 Fedora Update System 2021-10-16 01:14:44 UTC
FEDORA-2021-ab44a1d0c9 has been pushed to the Fedora 35 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.