Bug 200925 - Tar doesn't support xattr's (including SELinux context)
Tar doesn't support xattr's (including SELinux context)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: tar (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Vrabec
Ben Levenson
:
Depends On:
Blocks: xattrs-tracker 201916
  Show dependency treegraph
 
Reported: 2006-08-01 12:55 EDT by James Antill
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-10 10:01:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Just the patch for xattr support. (29.64 KB, patch)
2006-08-01 12:55 EDT, James Antill
no flags Details | Diff
Final rawhide patch for xattrs+SELinux+ACL support (43.96 KB, patch)
2006-08-09 14:43 EDT, James Antill
no flags Details | Diff

  None (edit)
Description James Antill 2006-08-01 12:55:06 EDT
Created attachment 133416 [details]
 Just the patch for xattr support.
Comment 1 James Antill 2006-08-01 12:55:06 EDT
Description of problem:
 GNUtar doesn't create archives with extended attributes in them, or create
extended attributes for files from archives that have them. This problem is even
worse due to the fact that ACL's and SELinux use xattr's

Version-Release number of selected component (if applicable):
tar-1.15.90-1.FC5

How reproducible:
Always

Additional info:
 I've now got a patch that adds --xattrs --selinux, and --no-xattrs --no-selinux
allowing tar to create/extract archives that have user/root xattrs and selinux
context xattrs. ACL xattr's aren't in it yet.
 It seems to work for me (tm).
 Note that no documentation is written for the above arguments, yet.

 The full srpms and i386 rpms are at (includes spec file changes, as well as patch):

http://people.redhat.com/jantill/
Comment 2 James Antill 2006-08-09 14:43:10 EDT
Created attachment 133871 [details]
Final rawhide patch for xattrs+SELinux+ACL support

 This is the final patch submitted to upstream. It includes ACL support,
documentation autoconf and a few other changes requested by upstream. Note that
this requires the LIB override hack to be removed from the spec file (works
fine if you just run the non-redhat code path).
Comment 3 Peter Vrabec 2006-08-10 09:09:01 EDT
patch applied 
tar-1.15.90-6
thx.  James

Note You need to log in before you can comment on or make changes to this bug.