Bug 201019 - rsyncd gets confused with timezones when logging to syslog
Summary: rsyncd gets confused with timezones when logging to syslog
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: rsync (Show other bugs)
(Show other bugs)
Version: 4.0
Hardware: All Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Jan Zeleny
QA Contact:
URL:
Whiteboard:
Keywords:
: 205326 (view as bug list)
Depends On:
Blocks: 575022
TreeView+ depends on / blocked
 
Reported: 2006-08-02 10:30 UTC by David Johnson
Modified: 2010-03-19 07:48 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 575022 (view as bug list)
Environment:
Last Closed: 2010-03-19 07:47:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description David Johnson 2006-08-02 10:30:04 UTC
Description of problem:
I'm running rsyncd and it seems to be getting confused with the time-zone when
logging. Here's a typical entry in messages:

Aug 2 09:30:01 rsyncd[8174]: rsync on /home from user@host (192.168.0.1)
Aug 2 08:30:01 rsyncd[8174]: wrote 2629 bytes read 122 bytes total size 626582

The correct local time is 09:30:01, whereas GMT is 08:30:01. So for some reason
it logs its first entry in local time, then the second entry in GMT. Every other
application logs using local time.

Version-Release number of selected component (if applicable):
2.6.3

How reproducible:
Always

Steps to Reproduce:
1. Run rsyncd
2. Connect to it and perform some operation

Actual results:
The two log entries generated by rsyncd in messages use different time zones.

Expected results:
The two log entries generated by rsyncd in messages both use local time.

Comment 1 David Tonhofer 2007-10-21 21:29:59 UTC
Same as bug #205326



Comment 2 Simo Sorce 2007-10-22 07:30:58 UTC
*** Bug 205326 has been marked as a duplicate of this bug. ***

Comment 3 Jan Zeleny 2010-03-05 10:04:59 UTC
Since there is only one more release of RHEL-4 planned and it will be focused on security and performance, I'm planning to close this bug as WONTFIX. Can you please confirm this behavior in RHEL5 or is it solved there?

Comment 4 David Johnson 2010-03-18 18:20:21 UTC
I'm afraid I no longer have a RHEL system to test this with, but I managed to find this upstream bug, which says that this bug was fixed in rsync 2.6.9:
https://bugzilla.samba.org/show_bug.cgi?id=2607

Comment 5 Jan Zeleny 2010-03-19 07:47:35 UTC
Thank you very much. It looks like the issue hasn't been fixed in RHEL-5. I'm copying the bug there and closing this one.


Note You need to log in before you can comment on or make changes to this bug.