Bug 2010250 - regresssion in iwlwifi firmware on upgrade for newer devices.
Summary: regresssion in iwlwifi firmware on upgrade for newer devices.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: linux-firmware
Version: 35
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: David Woodhouse
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException
: 2010522 2010610 2010749 2010927 2011126 2011457 2011581 2011661 2016593 (view as bug list)
Depends On:
Blocks: F35FinalFreezeException
TreeView+ depends on / blocked
 
Reported: 2021-10-04 10:45 UTC by František Zatloukal
Modified: 2021-10-22 08:49 UTC (History)
23 users (show)

Fixed In Version: linux-firmware-20210919-125.fc35
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-10-08 18:27:20 UTC
Type: Bug


Attachments (Terms of Use)

Description František Zatloukal 2021-10-04 10:45:02 UTC
Description of problem:
Since linux-firmware-20210919-123.fc35, the firmware files for Intel AX2XX wifi chipsets were split out into iwlax2xx-firmware subpackage. However, on upgrade from previous versions, this package doesn't get installed and as a result, the wifi is broken on devices using this wifi chipset.

Version-Release number of selected component (if applicable):
linux-firmware-20210919-123.fc35.noarch

How reproducible:
Always

Steps to Reproduce:
1. Upgrade linux-firmware package on laptop with Intel AX200 (or newer) wifi module

Actual results:
wifi doesn't work, iwlax2xx-firmware isn't installed.

Expected results:
wifi should work, iwlax2xx-firmware should be installed.

Additional info:
[   18.873261] iwlwifi 0000:52:00.0: Direct firmware load for iwlwifi-cc-a0-64.ucode failed with error -2
[   18.873292] iwlwifi 0000:52:00.0: Direct firmware load for iwlwifi-cc-a0-63.ucode failed with error -2
[   18.873317] iwlwifi 0000:52:00.0: Direct firmware load for iwlwifi-cc-a0-62.ucode failed with error -2
[   18.873341] iwlwifi 0000:52:00.0: Direct firmware load for iwlwifi-cc-a0-61.ucode failed with error -2
[   18.873365] iwlwifi 0000:52:00.0: Direct firmware load for iwlwifi-cc-a0-60.ucode failed with error -2
[   18.873389] iwlwifi 0000:52:00.0: Direct firmware load for iwlwifi-cc-a0-59.ucode failed with error -2
[   18.873412] iwlwifi 0000:52:00.0: Direct firmware load for iwlwifi-cc-a0-58.ucode failed with error -2
[   18.873436] iwlwifi 0000:52:00.0: Direct firmware load for iwlwifi-cc-a0-57.ucode failed with error -2
[   18.873472] iwlwifi 0000:52:00.0: Direct firmware load for iwlwifi-cc-a0-56.ucode failed with error -2
[   18.873494] iwlwifi 0000:52:00.0: Direct firmware load for iwlwifi-cc-a0-55.ucode failed with error -2
[   18.873516] iwlwifi 0000:52:00.0: Direct firmware load for iwlwifi-cc-a0-54.ucode failed with error -2
[   18.873537] iwlwifi 0000:52:00.0: Direct firmware load for iwlwifi-cc-a0-53.ucode failed with error -2
[   18.873560] iwlwifi 0000:52:00.0: Direct firmware load for iwlwifi-cc-a0-52.ucode failed with error -2
[   18.873765] iwlwifi 0000:52:00.0: Direct firmware load for iwlwifi-cc-a0-51.ucode failed with error -2
[   18.873789] iwlwifi 0000:52:00.0: Direct firmware load for iwlwifi-cc-a0-50.ucode failed with error -2
[   18.873812] iwlwifi 0000:52:00.0: Direct firmware load for iwlwifi-cc-a0-49.ucode failed with error -2
[   18.873914] iwlwifi 0000:52:00.0: Direct firmware load for iwlwifi-cc-a0-48.ucode failed with error -2
[   18.874009] iwlwifi 0000:52:00.0: Direct firmware load for iwlwifi-cc-a0-47.ucode failed with error -2
[   18.874099] iwlwifi 0000:52:00.0: Direct firmware load for iwlwifi-cc-a0-46.ucode failed with error -2
[   18.874188] iwlwifi 0000:52:00.0: Direct firmware load for iwlwifi-cc-a0-45.ucode failed with error -2
[   18.874279] iwlwifi 0000:52:00.0: Direct firmware load for iwlwifi-cc-a0-44.ucode failed with error -2
[   18.874369] iwlwifi 0000:52:00.0: Direct firmware load for iwlwifi-cc-a0-43.ucode failed with error -2
[   18.874460] iwlwifi 0000:52:00.0: Direct firmware load for iwlwifi-cc-a0-42.ucode failed with error -2
[   18.874551] iwlwifi 0000:52:00.0: Direct firmware load for iwlwifi-cc-a0-41.ucode failed with error -2
[   18.874641] iwlwifi 0000:52:00.0: Direct firmware load for iwlwifi-cc-a0-40.ucode failed with error -2
[   18.874736] iwlwifi 0000:52:00.0: Direct firmware load for iwlwifi-cc-a0-39.ucode failed with error -2
[   18.874744] iwlwifi 0000:52:00.0: no suitable firmware found!
[   18.874750] iwlwifi 0000:52:00.0: minimum version required: iwlwifi-cc-a0-39
[   18.874756] iwlwifi 0000:52:00.0: maximum version supported: iwlwifi-cc-a0-64
[   18.874763] iwlwifi 0000:52:00.0: check git://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git

Comment 1 Bastien Nocera 2021-10-04 10:53:41 UTC
Upgraded from F34 to F35 today and ran into this problem as well.

Comment 2 Kevin Fenzi 2021-10-04 18:09:01 UTC
Updated rawhide today and hit it. ;( 

it's particularly anoying since you have to find a wired connection to downgrade, you can't just boot a previous kernel. ;(

Comment 3 Peter Robinson 2021-10-04 18:10:51 UTC
> it's particularly anoying since you have to find a wired connection to
> downgrade, you can't just boot a previous kernel. ;(

Yes, I thought I got the upgrade process right, it's not like I'm out to make people's life difficult. I am working on it.

Comment 4 Adam Williamson 2021-10-04 18:45:11 UTC
Proposing as a Final FE - it would be a good idea to push the fix stable through the freeze tomorrow if it doesn't make it today, so people who upgrade during the freeze don't hit it.

Comment 5 Adam Williamson 2021-10-04 18:46:00 UTC
actually, on second thought, the broken update is only in -testing, so an FE is not needed.

Comment 6 Peter Robinson 2021-10-04 21:51:10 UTC
*** Bug 2010522 has been marked as a duplicate of this bug. ***

Comment 7 Peter Robinson 2021-10-05 08:13:47 UTC
*** Bug 2010610 has been marked as a duplicate of this bug. ***

Comment 8 Peter Robinson 2021-10-05 13:00:16 UTC
*** Bug 2010749 has been marked as a duplicate of this bug. ***

Comment 9 Milan Zink 2021-10-05 15:38:45 UTC
Exactly the same issue. Installing iwlax2xx-firmware fixes the problem.

Comment 10 Josh Boyer 2021-10-05 16:31:00 UTC
*** Bug 2010927 has been marked as a duplicate of this bug. ***

Comment 11 gjason 2021-10-05 19:53:19 UTC
I don't know if this is helpful or not, but I experienced this a little differently - when `dnf update` installed iwl7260-firmware version 1:25.30.13.0-122.fc35, dnf obsoleted & removed iwlax2xx-firmware.

Comment 12 František Zatloukal 2021-10-06 07:30:32 UTC
(In reply to gjason from comment #11)
> I don't know if this is helpful or not, but I experienced this a little
> differently - when `dnf update` installed iwl7260-firmware version
> 1:25.30.13.0-122.fc35, dnf obsoleted & removed iwlax2xx-firmware.

Yes, the issues is now a bit different than it originally was. The build in updates-testing was changed fixing the original problem but introducing what you describe.

Comment 13 Peter Robinson 2021-10-06 07:51:38 UTC
*** Bug 2011126 has been marked as a duplicate of this bug. ***

Comment 14 Fedora Update System 2021-10-06 12:22:13 UTC
FEDORA-2021-e353a56911 has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2021-e353a56911

Comment 15 Fedora Update System 2021-10-06 12:22:13 UTC
FEDORA-2021-e353a56911 has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2021-e353a56911

Comment 16 František Zatloukal 2021-10-06 12:28:01 UTC
So, all the dependency issues *should* be fixed with the latest build (that should get into -testing tomorrow).

Comment 17 Fedora Blocker Bugs Application 2021-10-06 12:29:57 UTC
Proposed as a Freeze Exception for 35-final by Fedora user frantisekz using the blocker tracking app because:

 Bunch of fw blob updates with fixes and HW enablement. Packaging errors should be fixed now, It's a good idea to get this into the GA in my opinion.

Comment 18 Peter Robinson 2021-10-06 16:03:56 UTC
*** Bug 2011457 has been marked as a duplicate of this bug. ***

Comment 19 darrell pfeifer 2021-10-06 17:46:16 UTC
20210919-125.fc36 installs the weak dependency properly for iwlax2xx-firmware.noarch. Wireless works properly after reboot.

Comment 20 Adam Williamson 2021-10-06 17:55:45 UTC
+3 in https://pagure.io/fedora-qa/blocker-review/issue/516 , marking accepted FE. However, I'll be checking the feedback carefully before actually pulling in the update to make sure all the issues have been fixed.

Comment 21 Josh Boyer 2021-10-06 19:39:02 UTC
*** Bug 2011581 has been marked as a duplicate of this bug. ***

Comment 22 Fedora Update System 2021-10-07 15:52:53 UTC
FEDORA-2021-e353a56911 has been pushed to the Fedora 35 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-e353a56911`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-e353a56911

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 23 Thomas Walker 2021-10-08 01:19:48 UTC
fwiw- I also picked linux-firmware-20210919-125.fc35.noarch (including weak dependency on iwlax2xx-firmware-20210919-125.fc35.noarch) this evening and can also confirm that the issues that I had beginning with the -123 release are fixed.

Comment 24 Peter Robinson 2021-10-08 06:50:50 UTC
*** Bug 2011661 has been marked as a duplicate of this bug. ***

Comment 25 Fedora Update System 2021-10-08 18:27:20 UTC
FEDORA-2021-e353a56911 has been pushed to the Fedora 35 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 26 Ben Boeckel 2021-10-20 11:58:02 UTC
Just an FYI, that I'm also seeing this on Fedora 34 with iwl7260-firmware-25.30.13.0-125.fc34.noarch Trying to upgrade to the Fedora 35 package now…

Comment 27 Peter Robinson 2021-10-20 11:59:49 UTC
(In reply to Ben Boeckel from comment #26)
> Just an FYI, that I'm also seeing this on Fedora 34 with
> iwl7260-firmware-25.30.13.0-125.fc34.noarch Trying to upgrade to the Fedora
> 35 package now…

You shouldn't, the broken version was never pushed. Do you have weak deps disabled?

Comment 28 Ben Boeckel 2021-10-20 12:01:28 UTC
Indeed, I do. Reading more closely, I see iwlax2xx-firmware is what I need; will try with that.

Comment 29 Peter Robinson 2021-10-22 08:49:22 UTC
*** Bug 2016593 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.