Bug 2010610 - Firmware load for AX200 fail with iwl7260-firmware-25.30.13.0-123
Summary: Firmware load for AX200 fail with iwl7260-firmware-25.30.13.0-123
Keywords:
Status: CLOSED DUPLICATE of bug 2010250
Alias: None
Product: Fedora
Classification: Fedora
Component: linux-firmware
Version: 35
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: David Woodhouse
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-10-05 07:59 UTC by Otavio R. Piske
Modified: 2021-10-05 08:13 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-10-05 08:13:47 UTC
Type: Bug


Attachments (Terms of Use)

Description Otavio R. Piske 2021-10-05 07:59:56 UTC
Description of problem:

Trying to load the firmware from the package iwl7260-firmware-1:25.30.13.0-123.fc35.noarch on my motherboard Gigabyte X570 I AORUS PRO WIFI/X570 I which has an Intel Wi-Fi 6 AX 200 device fails. 

Looking at the dmesg output, I have the following messages: 

iwlwifi 0000:06:00.0: Direct firmware load for iwlwifi-cc-a0-64.ucode failed with error -2
iwlwifi 0000:06:00.0: minimum version required: iwlwifi-cc-a0-39
iwlwifi 0000:06:00.0: maximum version supported: iwlwifi-cc-a0-64


Version-Release number of selected component (if applicable):
iwl7260-firmware-1:25.30.13.0-123.fc35.noarch

How reproducible:
Install iwl7260-firmware-1:25.30.13.0-123.fc35.noarch on a system with an Intel AX 200 device. 


Steps to Reproduce:
1. sudo dnf install -y iwl7260-firmware-25.30.13.0-123.fc35.noarch
2. reboot 
3. check if the wireless network is online (probably not)
4. check the dmesg output for messages complaining about version supported

Actual results:
- the wireless device is not working because the firmware cannot be loaded


Expected results:
- the wireless device should be working


Additional info:
- the work-around for this problem is to downgrade the package to version 122 (ie.: sudo dnf install -y iwl7260-firmware-25.30.13.0-122.fc35).

Comment 1 Peter Robinson 2021-10-05 08:13:47 UTC
Feel free to check for related bugs before filing new ones....

*** This bug has been marked as a duplicate of bug 2010250 ***


Note You need to log in before you can comment on or make changes to this bug.