Bug 2010381 - timeshift fails after util-linux upgrade
Summary: timeshift fails after util-linux upgrade
Keywords:
Status: CLOSED DUPLICATE of bug 1897979
Alias: None
Product: Fedora
Classification: Fedora
Component: timeshift
Version: 35
Hardware: Unspecified
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: srakitnican
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-10-04 14:19 UTC by Eduardo
Modified: 2021-11-26 22:56 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-11-26 22:56:25 UTC
Type: Bug


Attachments (Terms of Use)

Description Eduardo 2021-10-04 14:19:02 UTC
Description of problem:
timeshift operations using BTRFS fail with error:
E: ts: Failed to get partition list.

It behaves as it were starting in usb rescue mode only.

The error is due to a change in lsblk (util-linux). Versioning format changed colons to underscores (MAJ:MIN => MAJ_MIN)

Discussion about the error can be found in timeshift github:
https://github.com/teejee2008/timeshift/issues/425
https://github.com/teejee2008/timeshift/issues/753
https://github.com/teejee2008/timeshift/issues/755

A patch is already included in the source tree:
https://github.com/teejee2008/timeshift/commit/d437358ac3debf7625aefda4d0bd387a91b69df5#diff-5038e11d69860ae18e478e63e5f48c09b1ac2eb7a4c143f4b3e277523040712c

As patch:
https://github.com/teejee2008/timeshift/commit/d437358ac3debf7625aefda4d0bd387a91b69df5.patch


Version-Release number of selected component (if applicable):
timeshift-20.03-4
util-linux-2.37.2-1


How reproducible:
sudo timeshift --check
or
sudo timeshift --list
will trigger the error


Steps to Reproduce:
1. Install and setup timeshift using BTRFS
2. Run sudo timeshift --check

Actual results:
timeshift ends with an error:
E: ts: Failed to get partition list.


Expected results:
timeshift should not fail


Additional info:
A proposed patch is provided

Comment 1 ingli 2021-11-26 22:42:18 UTC
duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1897979 ?

Comment 2 Alessio 2021-11-26 22:56:25 UTC

*** This bug has been marked as a duplicate of bug 1897979 ***


Note You need to log in before you can comment on or make changes to this bug.