Bug 201189 - Keyboard Shortcuts -> Sound settings only affects Master channel
Keyboard Shortcuts -> Sound settings only affects Master channel
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: control-center (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Control Center Maintainer
David Lawrence
:
: 219896 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-03 10:26 EDT by Paul Dickson
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-16 05:18:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 173035 None None None Never

  None (edit)
Description Paul Dickson 2006-08-03 10:26:59 EDT
Description of problem:
If I press the media buttons on the font edge of my button, only the Master
channel settings are affected.  The Headphones channel remains unchanged.  To
change the Headphones setting, I must use the mixer_applet2 which changes BOTH
the Master and Headphones channel.

Version-Release number of selected component (if applicable):
control-center-2.15.4-6

How reproducible:
Always

Steps to Reproduce:
1. Assign some keys to volume up and down (Preferences->Keyboard Shortcuts).
2. Play some music.
3. Vary volume using keys, alternating built in speakers and headphones.
4. Vary volume using panel applet via left-clicks (Volume Applet aka mixer_applet2).
  
Actual results:
Key presses do not affect the headphone volume.  The volume applet keeps the
Master and Headphone channels locked together.

Expected results:
The keyboard shortcuts should operate with the Master and Headphone channels
locked together.

Additional info:
Comment 1 Bastien Nocera 2007-02-14 08:21:12 EST
*** Bug 219896 has been marked as a duplicate of this bug. ***
Comment 2 Bastien Nocera 2007-02-16 05:18:13 EST
This was implemented in:
http://bugzilla.gnome.org/show_bug.cgi?id=173035

It is now possible to choose which channel(s) you want to change with the
keybindings. It should already be in rawhide, and will be in Fedora 7.

Note You need to log in before you can comment on or make changes to this bug.