Bug 201233 - RFE: package additional command-line tools into nss-devel
RFE: package additional command-line tools into nss-devel
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: nss (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Kai Engert (:kaie)
:
: 211190 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-03 14:27 EDT by Nalin Dahyabhai
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-05 09:40:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nalin Dahyabhai 2006-08-03 14:27:39 EDT
The derdump and cmsutils samples which are built along with NSS are really handy
for debugging and generally diagnosing problems.  I'd like for them to be
included in either the nss-tools or (more likely) the nss-devel package so that
I won't have to build them myself.  There are probably other tools in there
which are similarly useful, but I haven't had occasion to use them yet.
Comment 1 Kai Engert (:kaie) 2006-09-20 16:47:29 EDT
I agree with your request, and we could include additional command line tools,
like pp, atob, btoa

My concern is, should we really be adding those tools with their very short
names, to the global search path? The tools are really intended for debugging only.

Would it make sense to add those tools to some non-default path, so we have them
available on the system, but they won't appear in the default search path?

Maybe in /usr/lib/nss ?

Opinions?
Comment 2 Wan-Teh Chang 2006-09-20 17:01:37 EDT
The Certificate System team also asked for atob and btoa
recently.  I am also worried that their names are too
short and not appropriate for /usr/bin.  Also these tools
would need to be added to our QA test script and need to
be documented in
http://www.mozilla.org/projects/security/pki/nss/tools/.
Comment 3 Kai Engert (:kaie) 2006-09-20 17:04:29 EDT
Wan-Teh, suppose we add the tools to
  /usr/lib/nss/debugging-tools

which is not in the default search path - could we live without QA and without
documentation?
Comment 4 Kai Engert (:kaie) 2006-10-18 23:32:14 EDT
*** Bug 211190 has been marked as a duplicate of this bug. ***
Comment 5 Rob Crittenden 2006-10-19 09:06:31 EDT
I'd like to add ocspclnt, selfserv and tstclnt to the list.
Comment 6 Bob Relyea 2006-10-19 11:20:21 EDT
We should make a pass at all the tools that NSS builds by default. Some tools
should be added to nss-tools. Those that aren't added to nss-tools should be
added to nss-devel. 

The nss-devel tools should live in a nss/debugging-tools directory (pick an
appropriate Linux home). Tools in nss-tools should be have priority in being
documented. The page at http://www.mozilla.org/projects/security/pki/nss/tools
should move to a wikki.

The tools that ship are a historical artifact. These are the tools that on one
time the 'tools' team picked up to support (and thus were included with any
server distribution). It was a minimal list.

bob
Comment 7 Kai Engert (:kaie) 2007-02-19 01:27:55 EST
The next nss rpm package, which will get published around the end of this week,
will ship additional tools in a new directory /usr/lib/nss/unsupported-tools.
For details see this page: http://wiki.mozilla.org/NSS:ToolsToShip
Comment 8 Kai Engert (:kaie) 2007-03-05 09:40:38 EST
fixed in rawhide and latest FC6 NSS package

Note You need to log in before you can comment on or make changes to this bug.