Bug 201281 - sk98lin driver missing & skge doesn't work with SK-9844 NIC
sk98lin driver missing & skge doesn't work with SK-9844 NIC
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-03 19:58 EDT by Don Buchholz
Modified: 2015-01-04 17:28 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-24 17:56:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Don Buchholz 2006-08-03 19:58:37 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.5) Gecko/20060719 Firefox/1.5.0.5

Description of problem:
I have a system with an older (circa 2002) SysKonnect SK-9844 NIC.  It has dual fiber (1000BaseSX) gigabit ethernet ports.  The adapter has worked quite well with the 'sk98lin' driver using many, many RedHat releases (7.3, RHEL3, RHEL4, FC3, and most FC4).  

However, when I updated to kernel packages versioned 2.6.17-1.2141_FC4 and 2.6.17-1.2142_FC4, I discovered the 'sk98lin' is no longer included.  A quick Bugzilla search indicated that 'skge' is the new, approved, SysKonnect/Marvell driver, however, this driver does not work with my SK-9844 (and we still have at least a dozen of these cards here).

The most recent working kernel I have for this system is 2.6.16-1.2115_FC4.

The 'skge' driver breaks with the messages:
  ... unsupported phy type 0x0
  ... probe of 0000:01:06.0 failed with error -95



Version-Release number of selected component (if applicable):
kernel-2.6.17-1.2142_FC4

How reproducible:
Always


Steps to Reproduce:
1.  Boot with "2.6.16-1.2115_FC4" and "alias eth0 sk98lin" in modprobe.conf.  Everything works fine.

2.  Boot with "2.6.17-1.2142_FC4" kernel and "alias eth0 skge" in modprobe.conf and the 'skge' module fails to load.


Actual Results:
I have no network connectivity and these two messages appear in /var/log/messages:

   skge 0000:01:06.0: unsupported phy type 0x0
   skge: probe of 0000:01:06.0 failed with error -95



Expected Results:
I expected to be able to use my SK-9844 adapter with the recent kernels.


Additional info:
It seems to me that one of two things must happen for these adapters to work again (under current releases):

 (a) The new kernels continue to include the [deprecated?] 'sk98lin' driver.

-or-

 (b) The 'skge' driver needs some work to support the SK-9844 adapter.
Comment 1 Dan Carpenter 2006-08-03 21:40:15 EDT
Try sky2 driver?  I forget which systems use the skge and which use sky2...



Comment 2 Andre Costa 2006-08-21 09:18:42 EDT
Hi,

this happens with a 3com 3c940 as well. We have a machine here with this card,
and after upgrading from kernel 2.6.14-1.1656_FC4smp to
kernel-smp-2.6.17-1.2142_FC4 network kernel module now fails to load (sk98lin.ko
is missing).

On 2.6.14-1.1656_FC4smp this card was handled by sk98lin module, which seems to
be missing on kernel-smp-2.6.17-1.2142_FC4. There is a
/usr/src/kernels/2.6.17-1.2142_FC4-i686/drivers/net/sk98lin dir, which suggests
that module support is available on the kernel, but it hasn't been generated
during build process.

The card appears on lspci as

02:02.0 Ethernet controller: 3Com Corporation 3c940 10/100/1000Base-T [Marvell]
(rev 12)

Until this is solved we'll have to stick this machine to kernel
2.6.14-1.1656_FC4smp. Please let me know if you need more info or if I should
open a separate bug report for this.

Regards,

Andre
Comment 3 Dave Jones 2006-09-16 23:10:19 EDT
[This comment added as part of a mass-update to all open FC4 kernel bugs]

FC4 has now transitioned to the Fedora legacy project, which will continue to
release security related updates for the kernel.  As this bug is not security
related, it is unlikely to be fixed in an update for FC4, and has been migrated
to FC5.

Please retest with Fedora Core 5.

Thank you.
Comment 4 Dave Jones 2006-10-16 20:18:42 EDT
A new kernel update has been released (Version: 2.6.18-1.2200.fc5)
based upon a new upstream kernel release.

Please retest against this new kernel, as a large number of patches
go into each upstream release, possibly including changes that
may address this problem.

This bug has been placed in NEEDINFO state.
Due to the large volume of inactive bugs in bugzilla, if this bug is
still in this state in two weeks time, it will be closed.

Should this bug still be relevant after this period, the reporter
can reopen the bug at any time. Any other users on the Cc: list
of this bug can request that the bug be reopened by adding a
comment to the bug.

In the last few updates, some users upgrading from FC4->FC5
have reported that installing a kernel update has left their
systems unbootable. If you have been affected by this problem
please check you only have one version of device-mapper & lvm2
installed.  See bug 207474 for further details.

If this bug is a problem preventing you from installing the
release this version is filed against, please see bug 169613.

If this bug has been fixed, but you are now experiencing a different
problem, please file a separate bug for the new problem.

Thank you.
Comment 5 Dave Jones 2006-11-24 17:56:23 EST
This bug has been mass-closed along with all other bugs that
have been in NEEDINFO state for several months.

Due to the large volume of inactive bugs in bugzilla, this
is the only method we have of cleaning out stale bug reports
where the reporter has disappeared.

If you can reproduce this bug after installing all the
current updates, please reopen this bug.

If you are not the reporter, you can add a comment requesting
it be reopened, and someone will get to it asap.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.