Bug 201291 - build olpc-kernel package for olpc hardware
build olpc-kernel package for olpc hardware
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Woodhouse
Brian Brock
:
: 201290 (view as bug list)
Depends On:
Blocks: OLPCTracker
  Show dependency treegraph
 
Reported: 2006-08-03 23:01 EDT by Christopher Blizzard
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-01 13:25:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christopher Blizzard 2006-08-03 23:01:41 EDT
Need to build out our olpc-kernel package for the hardware.  David Woodhouse has
a config file for the hardware here:

http://david.woodhou.se/olpc-config

That's apparently the _difference_ between the i686 config and OLPC.  There's
apparently a script in the kernel CVS that will build the config.
Comment 1 Dave Jones 2006-08-08 14:40:36 EDT
*** Bug 201290 has been marked as a duplicate of this bug. ***
Comment 2 Dave Jones 2006-08-08 14:48:33 EDT
Needs to be a set of overrides for the configs/ dir rather than a standalone
config file.

There's a number of oddities in the diff between 686 & OLPC that should fall out
if it's done this way, so I've not done a complete review of the changes.
Comment 3 Christopher Blizzard 2006-08-08 15:08:41 EDT
dwmw2 told me that that is what that file does - override the basic i686 config.
 Not sure if you were expecting a different format or something.
Comment 4 David Woodhouse 2006-08-09 04:47:45 EDT
No, I think I said (or certainly I _meant_ to say) that the scripts in the
kernel CVS directory are useful for making such 'config overrides' and that we
should so do instead of just using the raw file above.
Comment 5 Christopher Blizzard 2006-09-01 13:25:03 EDT
This is done, Marcelo has owned it.

Note You need to log in before you can comment on or make changes to this bug.