This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 201352 - default mapper order should be cn, uid,pwent
default mapper order should be cn, uid,pwent
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: pam_pkcs11 (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bob Relyea
:
: 201377 (view as bug list)
Depends On:
Blocks: 181386 181509
  Show dependency treegraph
 
Reported: 2006-08-04 11:37 EDT by Bob Relyea
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version: 5.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-13 09:55:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bob Relyea 2006-08-04 11:37:28 EDT
Description of problem:

pam_pkcs11 uses a mapper interface to map the certificate to a unix user.
for Fedora, the default order should be:

cn - maps a cn value to a user id based on a mapping file cn_map. Basic fallback
case.
uid - maps the unix user based on the uid attribute of the DN.
pwent - used the password file to map the cn to a user id.


cn is basically a user configurable override for a given cert.
uid is a TPS override for a given user.
pwent is for environments with NIS or ldap password entries.
Comment 1 Ray Strode [halfline] 2006-08-04 18:02:14 EDT
*** Bug 201377 has been marked as a duplicate of this bug. ***
Comment 2 Bob Relyea 2006-08-29 13:18:49 EDT
pam_pkcs11-0.5.3-14
Comment 5 Bob Relyea 2006-09-13 14:04:48 EDT
Fixed in pam_pkcs11-0.5.3-15
Comment 7 Orla Hegarty 2006-09-25 18:43:44 EDT
I can confirm that the order is now correct in RHEL 5 beta 2 milestone 3 (
candidate 20060921.0 ) on both x84_64 and i396

I will verify this bug is fixed once we have a stable candidate that [1]
installs and [2] in which the pam stack preventing smart card login does not
require a workaround ( bug#207410 ) 
Comment 8 Orla Hegarty 2006-10-12 14:32:08 EDT
VERIFIED fixed against candidate RHEL5-Client-20061006.2 

$ rpm -qa | grep pam_pkcs11
pam_pkcs11-0.5.3-22
pam_pkcs11-0.5.3-22
Comment 9 Jay Turner 2006-11-13 09:55:10 EST
Closing out as included in latest RHEL5 builds (20061111.0)

Note You need to log in before you can comment on or make changes to this bug.