Bug 201377 - default mapper order
default mapper order
Status: CLOSED DUPLICATE of bug 201352
Product: Fedora
Classification: Fedora
Component: pam_pkcs11 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bob Relyea
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-04 14:11 EDT by jmccann
Modified: 2015-01-14 18:19 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-04 18:01:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jmccann 2006-08-04 14:11:09 EDT
I have two accounts on the system:

mccannwj:x:729:128:William Jon McCann:/home/mccannwj:/bin/bash
mccann:x:730:730::/home/mccann:/bin/bash

% pkcs11_inspect
Printing data for mapper digest:
5D:0F:C5:B6:52:C9:CC:EF:EA:4D:16:5C:3C:30:64:B4:90:60:D0:41
Printing data for mapper uid:
mccann
Printing data for mapper cn:
William Jon McCann
Printing data for mapper pwent:
William Jon McCann
Printing data for mapper mail:
mccann@jhu.edu
mccann@jhu.edu
Printing data for mapper subject:
UID=mccann,CN=William Jon McCann,E=mccann@jhu.edu,O=Token Key User


So, currently the default mapper looks for CN before UID.  There are two
problems with this.

1. I can log into either the mccann or mccannwj account from console login
2. By default, gdm chooses the mccannwj user instead of the mccann user
Comment 1 Ray Strode [halfline] 2006-08-04 18:01:57 EDT

*** This bug has been marked as a duplicate of 201352 ***

Note You need to log in before you can comment on or make changes to this bug.