Bug 2013591 - [4.7] Openshift Installer| UEFI mode | BM hosts have BIOS halted
Summary: [4.7] Openshift Installer| UEFI mode | BM hosts have BIOS halted
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Bare Metal Hardware Provisioning
Version: 4.7
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: 4.7.z
Assignee: Derek Higgins
QA Contact: Amit Ugol
URL:
Whiteboard:
Depends On: 1972213
Blocks: 2025495
TreeView+ depends on / blocked
 
Reported: 2021-10-13 10:14 UTC by Yurii Prokulevych
Modified: 2021-11-22 14:52 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-10-27 08:22:59 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift ironic-ipa-downloader pull 86 0 None open Bug 2013591: Bump IPA version to 15.2-20211013.1 2021-10-14 13:44:17 UTC
Red Hat Product Errata RHBA-2021:3931 0 None None None 2021-10-27 08:23:18 UTC

Description Yurii Prokulevych 2021-10-13 10:14:29 UTC
This bug was initially created as a copy of Bug #1966129


Version:

$ ocp 4.7.33

Platform:
baremetal


Please specify:
IPI

What happened?
--------------
OCP installation failed 
3 baremetal masters stuck(screenshot attached)


What did you expect to happen?

BM nodes up and running. Probably something wrong with boot loader

How to reproduce it (as minimally and precisely as possible)?

This issue reproducible on all 4.7.33  on Dell Power Edge R740.

Comment 2 Derek Higgins 2021-10-13 10:38:51 UTC
Looks like 4.7.33 brought with it a newer RHCOS
https://github.com/openshift/installer/pull/5229

This updated to a newer version of shim
shim-x64-15-16.el8.x86_64 -> shim-x64-15.4-2.el8_1.x86_64

This shim package is broken, if the UEFI fallback boot patch is used 
(see https://bugzilla.redhat.com/show_bug.cgi?id=1970632 )

We have two options here
1. revert the RHCOS bump
2. Backport the ironic workaround into 4.7 (https://review.opendev.org/c/openstack/ironic-python-agent/+/795862)

Comment 7 Lubov 2021-10-17 07:35:53 UTC
@yprokule could you, please, verify on your setup? We've seen the problem is not happening on our Dell setup

Comment 9 Lubov 2021-10-20 13:54:32 UTC
verified on 4.7.0-0.nightly-2021-10-15-152957

Comment 11 errata-xmlrpc 2021-10-27 08:22:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.7.36 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:3931


Note You need to log in before you can comment on or make changes to this bug.