Bug 2025495 - [4.6] Openshift Installer| UEFI mode | BM hosts have BIOS halted
Summary: [4.6] Openshift Installer| UEFI mode | BM hosts have BIOS halted
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Bare Metal Hardware Provisioning
Version: 4.6
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: 4.6.z
Assignee: Derek Higgins
QA Contact: Lubov
URL:
Whiteboard:
Depends On: 2013591
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-11-22 11:32 UTC by Yurii Prokulevych
Modified: 2022-01-12 09:47 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, in UEFI mode, the `ironic-python-agent` created a UEFI bootloader entry after downloading the RHCOS image. When using an RHCOS image based on RHEL 8.4, the image could fail to boot using this entry. If the entry installed by Ironic was used when booting the image, the boot could fail and output a BIOS error screen. This is fixed by the `ironic-python-agent` configuring the boot entry based on a CSV file located in the image, instead of using a fixed boot entry. The image boots properly without error. ------- Cause: In UEFI mode, after downloading the RHCOS image, the ironic-python-agent creates a UEFI bootloader entry. When using an RHCOS image based on RHEL 8.4, the image may fail to boot using this entry. Consequence: Depending on the ordering of UEFI entries, if the entry installed by Ironic is used when booting the image the boot may fail and output a BIOS error screen. Fix: The ironic-python-agent will configure the boot entry based on a CSV file located in the image instead of using a fixed boot entry. Result: The image boots properly without an error.
Clone Of:
Environment:
Last Closed: 2022-01-12 09:47:25 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift ironic-ipa-downloader pull 88 0 None open Bug 2025495: Bump IPA version to 15.2-20211013.1 2021-11-22 14:53:08 UTC
Red Hat Product Errata RHBA-2022:0025 0 None None None 2022-01-12 09:47:29 UTC

Description Yurii Prokulevych 2021-11-22 11:32:06 UTC
Created attachment 1842990 [details]
Master console

This bug was initially created as a copy of Bug #2013591

I am copying this bug because: 



This bug was initially created as a copy of Bug #1966129


Version:

$ ocp 4.6.49

Platform:
---------
baremetal


Please specify:
IPI

What happened?
--------------
OCP installation failed 
3 baremetal masters stuck(screenshot attached)


What did you expect to happen?

BM nodes up and running. Probably something wrong with boot loader

How to reproduce it (as minimally and precisely as possible)?

This issue reproducible on all 4.6.49  on Dell Power Edge R740.

Comment 6 Lubov 2021-12-07 14:55:36 UTC
verified on 4.6.0-0.nightly-2021-12-06-112404

Comment 9 errata-xmlrpc 2022-01-12 09:47:25 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6.53 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2022:0025


Note You need to log in before you can comment on or make changes to this bug.