Bug 2013653 - TuneD: high CPU utilization of the TuneD daemon.
Summary: TuneD: high CPU utilization of the TuneD daemon.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Node Tuning Operator
Version: 4.10
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.9.0
Assignee: Jiří Mencák
QA Contact: Simon
URL:
Whiteboard:
Depends On: 2013321
Blocks: 2013678
TreeView+ depends on / blocked
 
Reported: 2021-10-13 13:16 UTC by OpenShift BugZilla Robot
Modified: 2021-10-26 17:23 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 2013678 (view as bug list)
Environment:
Last Closed: 2021-10-26 17:22:42 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-node-tuning-operator pull 279 0 None open [release-4.9] Bug 2013653: TuneD: workaround for high CPU utilization of [scheduler] plug-in. 2021-10-13 13:17:03 UTC
Red Hat Product Errata RHBA-2021:3935 0 None None None 2021-10-26 17:23:04 UTC

Description OpenShift BugZilla Robot 2021-10-13 13:16:52 UTC
+++ This bug was initially created as a clone of Bug #2013321 +++

Description of problem:
The fix for rhbz#1979352 introduced the [scheduler] plug-in as a standard part of openshift TuneD profiles. Unfortunately, the [scheduler] plug-in can be very CPU intensive, especially on the OpenShift platform. The bug for this issue is tracked by rhbz#1921738.  The CPU utilization of the TuneD process can be around 1% of one core.

Version-Release number of selected component (if applicable):
4.8->4.10

How reproducible:
Always.

Steps to Reproduce:
1. Install OCP
2. Watch tuned process utilization either via top -p <pid> or just by querying /proc/<pid>/status

Actual results:
~1% of CPU

Expected results:
~0% of CPU

Additional info:
https://github.com/openshift/cluster-node-tuning-operator/pull/278

Comment 2 Simon 2021-10-14 15:17:43 UTC
$ oc get clusterversions.config.openshift.io 
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.9.0-0.nightly-2021-10-14-063636   True        False         103m    Cluster version is 4.9.0-0.nightly-2021-10-14-063636

$ oc get nodes
NAME                                                        STATUS   ROLES    AGE    VERSION
skordas1013a-5jlfb-master-0.c.openshift-qe.internal         Ready    master   122m   v1.22.0-rc.0+894a78b
skordas1013a-5jlfb-master-1.c.openshift-qe.internal         Ready    master   122m   v1.22.0-rc.0+894a78b
skordas1013a-5jlfb-master-2.c.openshift-qe.internal         Ready    master   122m   v1.22.0-rc.0+894a78b
skordas1013a-5jlfb-worker-a-llhdj.c.openshift-qe.internal   Ready    worker   111m   v1.22.0-rc.0+894a78b
skordas1013a-5jlfb-worker-b-rzn2b.c.openshift-qe.internal   Ready    worker   111m   v1.22.0-rc.0+894a78b
skordas1013a-5jlfb-worker-c-l4knk.c.openshift-qe.internal   Ready    worker   112m   v1.22.0-rc.0+894a78b

# master node
$ oc debug node/skordas1013a-5jlfb-master-0.c.openshift-qe.internal
Starting pod/skordas1013a-5jlfb-master-0copenshift-qeinternal-debug ...
To use host binaries, run `chroot /host`
Pod IP: 10.0.0.4
If you don't see a command prompt, try pressing enter.
sh-4.4# chroot /host
sh-4.4# pidof openshift-tuned
16892
sh-4.4# top -p 16892

    PID USER      PR  NI    VIRT    RES    SHR S  %CPU  %MEM     TIME+ COMMAND
  16892 root      20   0 1495812  45028  26756 S   0.0   0.3   0:00.93 openshift-tuned

# worker node
$ oc debug node/skordas1013a-5jlfb-worker-a-llhdj.c.openshift-qe.internal
Starting pod/skordas1013a-5jlfb-worker-a-llhdjcopenshift-qeinternal-debug ...
To use host binaries, run `chroot /host`
Pod IP: 10.0.128.2
If you don't see a command prompt, try pressing enter.
sh-4.4# chroot /host
sh-4.4# pidof openshift-tuned
2504
sh-4.4# top -p 2504

    PID USER      PR  NI    VIRT    RES    SHR S  %CPU  %MEM     TIME+ COMMAND
   2504 root      20   0 1569800  44908  25452 S   0.0   0.3   0:00.70 openshift-tuned

# %CUP = 0

Comment 5 errata-xmlrpc 2021-10-26 17:22:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.9.4 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:3935


Note You need to log in before you can comment on or make changes to this bug.