Bug 2013678 - TuneD: high CPU utilization of the TuneD daemon.
Summary: TuneD: high CPU utilization of the TuneD daemon.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Node Tuning Operator
Version: 4.10
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.8.z
Assignee: Jiří Mencák
QA Contact: Simon
URL:
Whiteboard:
Depends On: 2013653
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-10-13 14:05 UTC by Jiří Mencák
Modified: 2021-10-27 08:15 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 2013653
Environment:
Last Closed: 2021-10-27 08:15:28 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-node-tuning-operator pull 280 0 None open Bug 2013678: TuneD: workaround for high CPU utilization of [scheduler] plug-in. 2021-10-14 15:52:03 UTC
Red Hat Product Errata RHBA-2021:3927 0 None None None 2021-10-27 08:15:49 UTC

Description Jiří Mencák 2021-10-13 14:05:22 UTC
+++ This bug was initially created as a clone of Bug #2013653 +++

+++ This bug was initially created as a clone of Bug #2013321 +++

Description of problem:
The fix for rhbz#1979352 introduced the [scheduler] plug-in as a standard part of openshift TuneD profiles. Unfortunately, the [scheduler] plug-in can be very CPU intensive, especially on the OpenShift platform. The bug for this issue is tracked by rhbz#1921738.  The CPU utilization of the TuneD process can be around 1% of one core.

Version-Release number of selected component (if applicable):
4.8->4.10

How reproducible:
Always.

Steps to Reproduce:
1. Install OCP
2. Watch tuned process utilization either via top -p <pid> or just by querying /proc/<pid>/status

Actual results:
~1% of CPU

Expected results:
~0% of CPU

Additional info:
https://github.com/openshift/cluster-node-tuning-operator/pull/278

Comment 3 Simon 2021-10-18 17:38:16 UTC
$ oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.8.0-0.nightly-2021-10-16-024756   True        False         34m     Cluster version is 4.8.0-0.nightly-2021-10-16-024756

$ oc get nodes
NAME                                                       STATUS   ROLES    AGE    VERSION
skordas1018-9t6j5-master-0.c.openshift-qe.internal         Ready    master   147m   v1.21.1+6438632
skordas1018-9t6j5-master-1.c.openshift-qe.internal         Ready    master   147m   v1.21.1+6438632
skordas1018-9t6j5-master-2.c.openshift-qe.internal         Ready    master   147m   v1.21.1+6438632
skordas1018-9t6j5-worker-a-86p29.c.openshift-qe.internal   Ready    worker   138m   v1.21.1+6438632
skordas1018-9t6j5-worker-b-8kpm2.c.openshift-qe.internal   Ready    worker   137m   v1.21.1+6438632
skordas1018-9t6j5-worker-c-6hkpd.c.openshift-qe.internal   Ready    worker   137m   v1.21.1+6438632


$ oc debug node/skordas1018-9t6j5-master-0.c.openshift-qe.internal
Starting pod/skordas1018-9t6j5-master-0copenshift-qeinternal-debug ...
To use host binaries, run `chroot /host`
Pod IP: 10.0.0.4
If you don't see a command prompt, try pressing enter.
sh-4.4# chroot /host
sh-4.4# pidof openshift-tuned
16790
sh-4.4# top -p 16790

    PID USER      PR  NI    VIRT    RES    SHR S  %CPU  %MEM     TIME+ COMMAND
  16790 root      20   0 1568624  44016  26664 S   0.0   0.3   0:02.01 openshift-tuned

sh-4.4# exit
exit
sh-4.4# exit
exit

Removing debug pod ...

# The same with worker node

$ oc debug node/skordas1018-9t6j5-worker-a-86p29.c.openshift-qe.internal
Starting pod/skordas1018-9t6j5-worker-a-86p29copenshift-qeinternal-debug ...
To use host binaries, run `chroot /host`
Pod IP: 10.0.128.4
If you don't see a command prompt, try pressing enter.
sh-4.4# chroot /host
sh-4.4# pidof openshift-tuned
2813
sh-4.4# top -p 2813

    PID USER      PR  NI    VIRT    RES    SHR S  %CPU  %MEM     TIME+ COMMAND
   2813 root      20   0 1495148  44628  26320 S   0.0   0.3   0:02.01 openshift-tuned

sh-4.4# exit
exit
sh-4.4# exit
exit

Removing debug pod ...

Comment 6 errata-xmlrpc 2021-10-27 08:15:28 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.8.17 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:3927


Note You need to log in before you can comment on or make changes to this bug.